3

I've completed all the quests for Proving Honor, it's on completed quests but it's not actually completed. Return to Jorrvaskr diamond is not filled in. When I try to continue in the game asking for work he says he already gave me work when I am finished. I can't use console commands because I'm playing on a PS4, so how do I continue in the companions story. I did the ceremony where he swears loyalty to me but it still doesn't let me continue in the story.

  • Do you have a previous save you could jump to? – Azifor Jan 26 '17 at 2:29
  • No after it happened I moved to other missions to see if it would fix itself later – Nathaniel Jan 26 '17 at 4:24
  • Hmmm sounds like a glitch but I'll let someone else decide and answer. Sorry that happened man – Azifor Jan 26 '17 at 4:42
  • @Nathaniel The tag you tried to add was not applicable, it is for a game called 'Glitch' – Angzuril Jan 26 '17 at 6:13
  • Did you participate in the initiation ceremony where Farkas swears loyalty to you? – pushasha Jan 26 '17 at 15:43
5

It sounds like you've encountered a known bug, with no known solution.

The Bugs section of the Elder Scrolls Wiki page on this quest says:

The quest registers as completed in the journal, before being completed, making the next quest in the series impossible to initiate.

Since you're playing on PS4, you'll need to load a prior save. If you don't have one, then you'll have to either give up on the Companions quest line or start a new character.

This is an Elder Scrolls game. Make saves often, at key points.

| improve this answer | |
-2

Ok my friend fond a way to fix this it is strange and takes some time but it works you have to make a new person and name him dadric then do the companion quests up to when you kill the silver hand and kill them with a silver sword head back to whiterun save it and go back to your world and you will have a new mission called family alum that is your next companion mission I did this myself so I know it works

| improve this answer | |
  • 2
    So your solution is to start a new game? – Wrigglenite Jan 27 '17 at 20:21
  • 3
    Did you create a second account to answer this? (Same name and account age) You are allowed to answer your own question, but there are issues regarding multiple accounts – Angzuril Jan 27 '17 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.