-1

As stated in the title, we get the error Minecraft: java.net.connectexception whenever we try to connect to each other's LAN worlds. We have tried several fixes including:

  • Using Hamachi
  • Turning off our firewalls
  • Creating new inbound rules for Minecraft
  • Installing a different version of Minecraft

Nothing so far has worked. We can connect to other servers just fine, but can never join each other's LAN worlds.

Any suggestions or fixes, would be greatly appreciated.

Thank you in advance you wonderful person <3.

marked as duplicate by galacticninja, greg-449, Gigazelle, Ivo Coumans, Wondercricket Sep 9 at 12:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • By rule you mean port? – Reflexive Feb 1 '17 at 10:49
  • I know you mentioned that you messed with the firewall and firewall rules on your PC, but I would try these steps posted by Void Walker in the order they listed. – DrZoo Feb 1 '17 at 15:37
  • Thank you for the advice, i tried all of these steps previously, none of them yielded results. – ValorousKoala Feb 1 '17 at 19:36
  • Are you both on the same network? (ie. connected to the same router/switch) – Zymus Jul 21 '17 at 19:16
  • @galacticninja Can you expand on how are they the same? This one seems to be having a problem with Java, whereas the suggested duplicate is a Minecraft server issue (it seems to my Minecraft-layman eyes). – Joachim Sep 8 at 8:40
0

I believe that this is probably a firewall problem. Have both of your computers have firewall disabled on both public and home networks? My sister and I tried this after going days without being able to play lan and it worked but if you do not wish to do this then here is a way to let programs through your firewall, not ports. And also realise that Minecraft now has built in Java so please post the executable path in the launcher's edit profile section. So to begin go to the start menu and paste this in:

Control Panel\System and Security\Windows Firewall\Allowed Programs

Then click change settings:

Allow Programs section

Then press allow another program...:

And then what you must do is paste what is in your executable which you found in the Minecraft launcher: Executable Location . And then click add. I hope this help's you

  • Thank you for the answer :), but i already tried doing that, it didn't have an effect and the problem persisted. I attempted doing it again, but it gave me a message saying that i already added that to the list of exceptions. – ValorousKoala Feb 1 '17 at 19:24
0

My brother and I had the same problem. I couldn't connect to his server and we used the exact same programs.

Here's the solution: swap roles, have whoever is hosting at the moment try letting the other person try hosting instead.

We tried this, so now I'm hosting. Now, my brother and I can finally play together.

  • And please put your firewall backup!!! – AmberStarDust Jul 31 '17 at 7:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.