2

I installed Homeworld Cataclysm on my Windows 10 machine, applied the 1.01 patch, and tried recommended command line settings I found in various threads online, such as cataclysm.exe /heap 256000000 /enableSSE /triple /disableAVI /safeGL. One recommended thing I wasn't able to do is set compatibility options to NT, which isn't available as an option in the compatibility settings, but I tried other compatibility settings (Windows 95, 98, XP SE2, XP SE3). I'm also running it in administrator mode.

Right now, what I see is that the game doesn't even run. Upon double clicking nothing happens except that Windows brings up a dialogue box asking if this program was installed correctly and if I want to do compatibility troubleshooting.

From reading other people's accounts, it sounds like most people are, at the very least, able to get it to launch. What am I missing?

  • When you say other options, what did you try? You should be able to set the compatability mode of an application via troubleshooting it or by right clicking the .exe file and selecting properties -> compatibility. – Timmy Jim Feb 3 '17 at 17:25
  • @TimmyJim I meant that I tried the compatibility options that were available. I edited the question to clarify. – Nikita Kiryanov Feb 3 '17 at 17:41
1

I found someone describing how they got Homeworld Cataclysm to work on windows 10.

Source: Link to window 10 cataclysm setting

Starting Options: Okay i had to apply some things to the shortcut (if not present, make one) in >order to make it work:

cataclysm.exe /heap 256000000 /enableSSE /triple /disableAVI /safeGL

I believe this is the setting you were looking for.

  • 1
    This was one of the setting combination I tried. Still doesn't launch. I also found other threads that recommend different combinations and still nothing. – Nikita Kiryanov Feb 3 '17 at 20:16
  • Hmm it may be hardware specific. I don't know what else to do without more data. – Vyndicu Feb 3 '17 at 21:31
1

I got Cataclysm to work on Windows 10 a while ago, so I know it's possible. From what I remember, the required compatibility mode was removed in Windows 10, so I had to make my own. This is the process I used, to the best of my recollection, but it's been a while.

  1. Download and install the Microsoft Compatibility Toolkit.
  2. Download this compatibility database
  3. Run "Compatibility Administrator (32-bit)"
  4. Open the database you downloaded in (2). It should appear as "Homeworld Cataclysm" under "Custom Databases" in the tree on the left pane.
  5. Right-click "Homeworld Cataclysm" and click install.

The database I'm using likely includes more compatibility fixes than actually required, but I just copied one of the pre-made compatibility modes and tweaked it a bit (don't ask me what I changed; I don't remember).
There's a similar database linked from the Cataclysm page on PCGamingWiki that contains fixes for both Cataclysm and the original Homeworld. I gave it a quick try and it seems to work as well, so try that one if the one I made fails for some reason.

That, along with the command line flags from your question should hopefully get everything working. For completeness sake, these are the command line flags I have set:

/triple /enableSSE /enable3DNow /disableAVI /heap 1073741824 /window /noBorder

You may also have to fiddle with the registry settings under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sierra On-Line\Cataclysm I seem to recall having to set glToSelect to opengl32.dll, and you can also set the screen resolution higher than the in-game settings allow (though widescreen resolutions cause some issues).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.