I have portable minecraft installed on a USB drive. I followed these steps:


It worked just fine with and without mods. The new launcher just came out and it doesn't find the data from the USB. It finds the data from the PC I run it on which also has minecraft installed.

How can I fix this so it really is portable again?

If I can make it use only the 'old' launcher that would be even better.

enter image description here

PS: If you can think of any more tags for this post that would be great! I can't find any launcher or portable tags. :P

  • 2
    Just to make sure, was this copy of Minecraft purchased?
    – Vemonus
    Feb 6, 2017 at 18:04
  • Yes. This is an official account. Feb 6, 2017 at 20:03
  • @Vemonus It is obvious that he purchased it. Otherwise he won't be playing it.
    – Fennekin
    Feb 11, 2017 at 10:58

3 Answers 3


PLEASE MAKE SURE TO BACK UP YOUR SAVES FIRST! This shouldn't delete them or anything, but it's always a safe bet. Also settings and resource packs if you care about those too.

I think this will work for you. Assuming you're using the batch file like the one in the post you linked to, I recommend replacing its contents with the following:

“%CD%\bin\Minecraft.exe” --workDir "%CD%\data" --lockDir %CD%\data\.minecraft

If the launcher doesn't start up, add start "" to the beginning of the line, and that should function correctly. If it does not, leave me a comment and I will look at it again when I'm not dead tired.

I'm actually working on my own variation of this and have run into problems myself.

  • Yours and Hail's answers were pretty good... I feel jealous. :( Keep going with these answers - they're good! :D Jun 29, 2017 at 19:29
  • Also, I should note that the way I set mine up, I have to restart the launcher after an update (to the launcher itself, not the game), but only if there is a space in the directory. (ex. "F:\This Folder" requires a restart)
    – Caleb
    Jul 3, 2017 at 4:51

Minecraft on a USB-Drive, is it possible?

The short answer: yes- no?

The basis of this, is that:

  1. When the Minecraft Launcher is run from the USB's Directory, it will first try to find a copy of the Minecraft Game on the Host Computer first before trying anything else.
  2. If it does find a game on the Host Computer (meaning launcher and game files), it'll load that up: if not, it'll proceed to the USB's copies.
  3. However, note - Minecraft was not meant to be made Portably-Playable - yes, it can be portable if you do the right 'things', but this wasn't the intended purpose. Anything close to portable, would equal to carrying around the Minecraft Installer on the USB everywhere. Which, frankly, sucks. :sad face:

However, don't let my answer cow your judgement, you can carry the game files with you and proceed to any computer that already has Minecraft installed and ready - just perform the ol' switch-a-roo with the world saves and that, when you're done, reset it to how it was (or restore from another backup file) .

Is it actually possible?

Yes, it is.

Just keep your game files and the .jar in the same area of the USB and pray that it will work...

But if it doesn't work, then it obviously wasn't intended to be. However, with the new advancement in Java Technologies, the minecraft.jar should have a precompiled 'assistive' java-library. Meaning the java-library is stored along with the game files. So... I don't really know myself by this point. All I can say is try. Keep in mind that this answer was provided with logic and common-knowledge, if you want to know more about how the Java-8 Launcher affects this process, head to the Reddit Post by Dinnerbone , you'll see an explanation as to why they moved to Java 8.

Good day/night.

  • It is perfectly and fully possible to run Minecraft on a USB drive. Even if there is a locally installed copy.
    – Manchineel
    Jun 29, 2017 at 13:35

I was having the same issue. Caleb's answer helped me solve it, Minecraft now runs on my USB without writing to the HDD.

Caleb's original solution was causing an error to something along the lines of "Minecraft.exe" could not be found.

I ended up changing the batch file to say:

start=%CD%/bin/minecraft.exe --workDir "%CD%\data" --lockDir %CD%\data.minecraft

And it ended up working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .