3

I cannot access the DLC area of Dark Souls 1 because the Crystal Golem in Duke's Archive is not dropping the broken pendant.

There are quite a few threads on the web regarding this issue but most of them seem to be from a time when the game still got patched and the issue seems to be resolved.

However, I think that it might have something to do with the Xbox One compatibility program (hence the Xbox One tag).

I bought the digital Xbox 360 version of the game. I run it on my Xbox One thanks to the backwards compatibility program.

At first I thought it might be because I don't have the DLC. Looking at the 360 store I saw that I could still buy it, so I bought it. Oddly enough, my Xbox One didn't prompt an update or other kind of download. However, I still can't access the DLC. I own Dark Souls 1 (Xbox 360 version) and the Artorias DLC (Xbox 360 version).

Is there any way to determine whether the DLC is actually unlocked? And how to force the Golem to drop the pendant?

I killed the golden golem in Darkroot Basin and talked to Dusk of Oolacile.

I tried

  • Restarting the game (the application)
  • Restarting the Xbox One (cold start)
  • Kill the Golem in the Archives as a Hollow and in human form
  • Warp out of the Duke's Area and back in
  • 1
    Dumb question: once you downloaded the DLC, did you install it? – Ben Feb 21 '17 at 1:20
  • 1
    I'm used to buying stuff in the store and it automatically downloads and installs it. I have never manually installed anything I bought digitally on the Xbox One. I will check it. – Exa Feb 21 '17 at 9:07
  • That can sometimes happen. – Ben Feb 21 '17 at 9:20
  • Looking the game up in the store resolved my problem, seems to be related to downloadable content for backwards compatibility games (see my answer for details). – Exa Feb 21 '17 at 9:32
4

As mentioned by Ben as a comment to my question, I checked if I could manually install the DLC.

In "Games & Apps" on the Xbox One there was no DLC in the category "Ready to install". However, when I opened the store and visited the page of the DLC I received a prompt to install the DLC.

I installed it and the Golem in the Duke's Archive dropped the pendant.

The problem came up because of the following situation: I could buy Dark Souls 1 (360 version) via the Xbox One store. However, when trying to buy the DLC it told me to buy it via Xbox.com or the 360 store on the 360 console. Buying it through Xbox.com resulted in my Xbox not automatically downloading and installing the DLC.

Usually, when I buy a game from the website, my Xbox One automatically installs it. Very useful feature when I buy games at work and come home to see them already downloaded and installed. However, this seems not to work for downloadable content of 360 games that are available in the backwards compatibility program.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.