1

I was doing a mirror project in Minecraft, when I ran into this problem. I'm trying to use a command that will place a player's head in the given coordinates. All of it worked, except that instead of placing a player's head, it placed a normal skeleton skull. How do I fix this command? Here's the command I placed:

/setblock -1393 66 1704 minecraft:skull 1 3 {SkullOwner:"Illeloria"}
1

Unlike the item variant for skulls, the metadata value for the skull block does not determine type, instead specifying directional facing. The SkullType tag determines the type of skull.

Also unlike the item variant, the player information is not stored in a tag called SkullOwner. You'll want to use ExtraType instead, which transforms into the relevant Owner compound (see here for a description of that format).

/setblock -1393 66 1704 minecraft:skull 1 0 {ExtraType:"Illeloria",SkullType:3}
  • This is good. Is this for recent versions? I haven't played in a while, but I'm playing in 1.11.2 and the command I gave I thought worked. But last time I used the command, was in 1.9. Also, This command worked with the command "give @p", it just didn't work for setblock. – Illeloria Gaming Mar 6 '17 at 3:46
  • It's essentially always been this way. Tile entity data for skulls isn't the same as item data, so you won't be able to copy/paste /give for /setblock and vice versa. The wiki also details the item variant's NBT data here. – Skylinerw Mar 6 '17 at 4:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.