8

I'm sure that this is possible as a "trading card idler" program ArchiSteamFarm can mark item notifications as read (I don't know how the feature works when you're playing a game instead of "idling"):

DismissInventoryNotifications - bool type with default value of false. Every card drop triggers inventory notification - Steam notification telling you that you received new items. This can get annoying pretty fast, and serves little to no purpose, therefore ASF offers dismissing those notifications automatically. When you enable this option, ASF will automatically dismiss all notifications related to new items being received - this also includes items you obtained through trading and other ways. Of course, this option affects only inventory notifications, so all other notification types, e.g. profile comments notifications, will stay intact.

Other notification categories on Steam:

  • comments
  • chat
  • invites
  • gifts

Currently Steam doesn't offer an option to disable notifications globally. It is always unclear whether I've receive a message from a friend or a trading card drop worth of 0.01$.

notification icon

  • 2
    This question is not a duplicate as I'm not asking for a way to disable notifications altogether. – user598527 Mar 8 '17 at 19:40
  • If you're talking about those little annoying notification windows popping up every now and then.. yes, you can disable them globally. – dly Mar 9 '17 at 7:38
  • @dly: No, I'm not talking about "announcements" (settings > interface > notify me about....). See the screenshot in my updated question. – user598527 Mar 9 '17 at 8:09
1

ASF manages this because the author built that feature into it. It listens for notification events from the Steam server itself the same as the client does when it's connected. When it gets a notification it checks if it's for a card drop, and "opens" it or otherwise does something to tell Steam the user has seen that notification.

The closest thing I know of that can easily be done is use a custom skin to keep the notification bubbles from popping up by limiting them to 0 seconds and a maximum of 0 notifications in the stack at a time.

  • 1
    Unfortunately I haven't been able to use your custom skin — I moved steam.styles file to ~\Program Files (x86)\Steam\skins (I also tried creating a folder for the skin) and the skin doesn't appear in Steam client, I only have "default skin" option available in the interface settings. In any case, you should add installation instructions to your repository. – user598527 Jan 9 '18 at 9:25
  • @user598527: Excellent point, sorry about that! Just pushed an update to the readme with installation directions including default Steam installation directories for each platform and the skin directories (because it's different on Mac). Also includes DIY directions for those who would rather not download it. I think the issue is that the steam.styles file needs to be in a resource folder inside the skin folder, like ../Steam/skins/Skin Folder/resource/steam.styles. Which also points out that I forgot the resource folder in the skin...lol -- sorry; also fixed that with the update. – l3l_aze Jan 9 '18 at 11:23
  • 1
    I'm sorry, but after updating there still is no custom skin in the dropdown menu. Are you able to select the skin? – user598527 Jan 11 '18 at 20:33
  • Sorry; I've been bedridden with bronchitis for a few days now. Still screwed up, but almost clear [cognitively] again. The update above was also messed up =\\ -- the steam.styles file is supposed to be at ../Steam/skins/Skin Folder/resource/styles/steam.styles, but I was too messed up at the time and should've waited to fix that. Updated again, and tested the GitHub Clone/Download to ensure it's working. Sorry, again. Please PM me if you have any other issues with this; don't want to take over the thread any more than we have already, lol. – l3l_aze Jan 12 '18 at 20:24
  • 1
    The skin can now be selected, thank you for actively responding to questions and fixing the issue. – user598527 Jan 13 '18 at 20:14
1

The aforementioned ASF can be run in paused state, persistently on the background and set to start when you launch your computer:

I don't want ASF to farm any games by default, yet I want to use extra ASF features. Is this possible?

Yes, you can set Paused bot config property to true in order to launch ASF with paused cards farming module, then you can make use of extra ASF features, such as GamesPlayedWhileIdle.

Then add DismissInventoryNotifications to your bot configuration file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.