2

On this mod on Xbox One Skyrim Special Edition, every time I enter Jonestead at the start of the mod, my game crashes and I have to load up the game again. It keeps happening and I've tried to fix, this but nothing works.

2
  • What other mods do you have installed, if any? Also, what all have you tried to do to fix it already?
    – Vemonus
    Mar 9, 2017 at 18:42
  • Well I have istalled many big quest mods such as the forgotten city and wheels of lull and moon and star and I actually looked up the full description of the mod telling me everything about it and the problems and I've looked at solutions like disabling big mods that interfere with it and I've done it and other things like I've started a whole new game to play this and it's still not working
    – Hartz4213
    Mar 9, 2017 at 18:50

2 Answers 2

2

There are 4 "Maids 2" asset packs you need to install on top of the main install. Without them you'll be unable to play at all.

-1

I had that same problem, and it was because I didn't have the other required mods for Maids 2 running. The critical one that must be running is "Maids 2: Assets." There are a couple others, but they are optional.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .