5

I have 2 Ubisoft games on Steam, Assassin's Creed III and Valiant Hearts. I've bought them a while ago, and they seemed to work, I've played them a lot.

But now, when I try to run them, the mouse icon loads for a few seconds and nothing. Nothing happens. I checked my computer processes and there is no "Valiant Hearts" or "Assassin's Creed III" process running.

I can't launch the game from the shortcut, nor steam, nor the Uplay launcher.

What I have tried:

  • Reinstalling Uplay: This seemed to work in the first place (before I did that, the uplay launcher wouldn't launch as well). After reinstalling, the uplay launcher started to launch, and I was able to play the games once, and then the problem returned. Now, I can open the uplay launcher, but can't launch any games.
  • Going Offline: I've read in some internet forums that going offline could help me. I tried. Nothing.
  • Update: Tried running all as administrator, didn't work.

I don't have anymore ideas. I don't think that this is an installation problem because I was able to play the games, the problem appeared out of nowhere.

Here are my device's specifications:

  • Windows 10
  • AMD FX Quad-Core Processor
  • NVIDIA GForce GT680
  • 8GB of RAM.

UPDATE

I don't know what happened. I didn't did anything, but today i just tried to start the games and they worked. It seems that uplay is pretty unstable. However, i'll leave the question (and bounty) open, if someone appears with a permanent solution (i don't know how long my games will be working).

  • I've looked on the internet and found a lot of people with this problem, but no definitive solution... – Vitor C Goergen Mar 13 '17 at 2:21
  • Did you ever try to simply reinstall the games? – Y U NO WORK Mar 13 '17 at 10:37
  • I did it only with Assassin's Creed III. It didn't work. – Vitor C Goergen Mar 13 '17 at 14:09
  • Forget steam for now, it's just call for Uplay to open with the game. When you try to start the game in Uplay what happens exactly? – George Wurthmann Mar 14 '17 at 19:43
  • Nothing. I launch uplay (it opens okay). Then i try to launch the game and nothing happens. – Vitor C Goergen Mar 15 '17 at 22:12
2
+50

I have similar problems with Uplay,

there are several posts of user around internet(reddit, Ubisoft forum and so on) complaining about those things.

There are two main and constant problems:

  • Can't download/update a Uplay Game
  • Can't open a Uplay Game

Every single forum, reddit post will tell you to:

  1. Open as administrator
  2. Reinstal the Game
  3. Reinstal Uplay
  4. Reinstal Dx
  5. Port foward
  6. Add Uplay+Game on trusted programs in Windows/Anti-Virus
  7. Close background application.

None of them will work.

If you get luck and receive support they will tell you to do the same again, but for no reason don't follow their advice to disable all windows services from msconfig because that may mess your computer and you will be unable to start windows again.

The only way to find what is really happening is investigating your computer.

You can check the Uplay logs here

Program Files (x86)\Ubisoft\Ubisoft Game Launcher\logs

(

And search google for the exact problem.

You can use the windows Resource Monitor to check the applications. And Windows Event Viewer for some anomaly.

Sadly, most of the time it was a problem with Ubisoft

Can't download/update a Uplay Game:

It was caused, most of the time, for a Ubisoft Server refusing to send a package, just one package (network log)

I found 4 possible solutions:

  • Wait
  • Change your IP, if your ISP allows that.
  • Try another ISP if you have two or more at home, you can use your mobile internet to download that last package.
  • Download it on a friend, or find a fried with the game downloaded/updated and copy to yours.

Can't open a Uplay Game

It could be caused by needing some third party software, but mostly by Uplay failing to verify it as yours or its dependencies (preventing you to play it), it may vary from game.

In this case I found only two solutions:

  • Wait (Uplay updates sometimes fix that, but not always)
  • Format PC (try in another computer first)

Don't forget to check Uplay logs before trying any drastic measure.

  • 1
    I would like to add to this answer that restarting your computer might close the processes and solve the problems in a few cases, as Codingale stated. For me this is the best answer because it tells me alternative ways beside "reinstall, call support, run as admin". In my case waiting was what actually solved my problem. Thank you all. – Vitor C Goergen Mar 20 '17 at 14:11
2

To list the things can mess it up

  1. Corrupted installation of uplay, which could also make installing games through uplay corrupted, reinstalling is the only option I can think of.
  2. Some background process is messing up your uplay (maybe a process you accidentally installed), try to quit every background process which isn't necessary and try to launch uplay/the games then
  3. Internet connection can make you client go haywire, going offline could fix this (but apparently that's not the problem)
  4. One other problem is, and this is farfetched, it could be a virus which is blocking you from launching the games. This means that you could potentially solve it by cleaning up your entire pc.

If these problems persist and none of the fixes listed above work. I would suggest that you will contact Ubisoft support. They know more about their own product hopefully and probably can fix your problem.

  • About 3, i have tested. About 4, i do scans on my computer monthly, and found nothing. The number 2 i already did, nothing changed. As i stated in a comment, for number 1 i tried reinstalling ACIII and it also didn't work. – Vitor C Goergen Mar 16 '17 at 14:46
  • Well than one solution is calling ubi support or sending in a ticket. other is wiping you pc and reinstalling everything (but I would advise you not to do that) – Wouter Mar 16 '17 at 15:26
2

Had a similar problem with uplay games.

What fixed the issue for me was setting everything(steam, uplay, game) to launch on administrator mode. To do so, you need to find the .exe right click it and open properties then go to compatibility tab and mark to launch as admin(you can mark to run in compatibility mode as well since you're using win10).

Also, if it still not working try disabling uplay and steam

EDIT: Sign out of steam BETA participation

  • What does it mean disabling steam and uplay overlays? – Vitor C Goergen Mar 16 '17 at 14:43
  • @Dovah-king, You can open steam's overlay by pressing Shift + Tab in a game by default, some games have some trouble with it so you can disable on steam settings. Same thing for Uplay, default keys ofr it are Shift + F2. I would suggest disabling Uplay's on first and if it doesn't work try steams one. – Kiogara Mar 16 '17 at 15:32
  • Disabled both. Didn't work. In my library in steam, it says "playing" for about 2 or 3 seconds, then it comes back to normal. – Vitor C Goergen Mar 16 '17 at 19:38
  • You can try to change the dysplay mode on game settings files at Documents\My Games\_Game_ . I don't have these games so I don't really know the name of the keys but it should be something like DisplayModeType or WindowMode. Value of this key shoud be 0, 1 or 2 meaning fullscreen, windowed and borderless. And have you actually updated your drivers with something like driver booster?? Do you restart your computer often? – Kiogara Mar 16 '17 at 21:31
  • My drivers are up to date. I almost never turn my computer down, however i did restart it a few days ago and it didn't change a thing. – Vitor C Goergen Mar 16 '17 at 22:09
0

I had a similar problem some time ago. The Ubisoft support staff listed these options available for me. Maybe you could retry step 1 or make sure you tried 2 and 3.

  1. Re-install Uplay Client - including backupping save games, uninstalling, downloading a current version and installing it "as Administrator"
  2. Update Drivers for your graphics card - just in case you haven't done it already
  3. Find the *.exe of the game - Make a shortcut of that file. Right click on that shortcut, select the "Run with graphics processor" menu, and select "High-performance NVIDIA processor."

If none of these work for you, I'd suggest contacting the Ubisoft support.

  • I did step 2, didn't work as well. The step 1 i stated in the question, i've tried, it worked once, and then the problem came back (i tried reinstalling again, didn't work). About the 3: I can't find the option "run with graphics processor" when rightclicking on a shortcut. – Vitor C Goergen Mar 16 '17 at 14:48
0

I figured out the problem myself while testing and if anyone else is having the problem here is the solution,

  • Right click on the uPlay Icon
  • Look for a program called 'Ubisoft Game Launcher'
  • Right Click and Run as Administrator

This worked for me and if anyone else is having the problem here is a possible solution

0

I had this same problem for the longest time, it seemed to occur after I changed the location of my games to my (E:) hard drive. I tried to reinstall both Uplay and the game but nothing worked. so what I did was move my Uplay app (which had been in my (C:) drive) to my (E:), then I reinstalled my game to my (C:). I am not sure if changing the location of my uplay app was the difference but I am confident that installing my Ubisoft games to my (C:) drive fixed the problems.

In short: INSTALL UBISOFT GAMES TO YOUR (C:) DRIVE.

  • Other solutions that may have led to this outcome:

    1. moving all steam and Ubisoft folders to E:
    2. deleting any duplicates on C:.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.