About four or five months ago, my PS4 deleted all of the updates for Call of Duty: Black Ops 3 and it told me that my data was corrupt so I had to delete it and reinstall. This was annoying on its own, but I downloaded 19GB worth of updates and hopped on for a game with my friends. I started lagging so bad that I rage quit and started playing a different game.

I booted BO3 up again the next day and my updates had deleted themselves again. Getting really annoyed, I quit BO3 and played a different game for about a month. Something I should mention is that my PS4 seemed to believe that I had the digital version of BO3, which I did not.

Then, I decided that I was going to re-download it one last time and this time it worked. In February of this year, I got the new Call of Duty (IW) and I downloaded 15 GB worth of updates. I started playing and enjoyed myself. However, now, in March, I got two new games.

Once I installed both of them, IW's updates got destroyed again, but I didn't mind that much. I updated my new games (4GB 15GB) and I played them yesterday. Today, I booted my PS4 up and my updates are gone again. It appears that no one else on the internet is having this problem, except those with Xboxes, but that doesn't help me. How do I fix this?

I have tried. My PS4 has about 40GB worth of space left, though I don't think that thats the actual number.

  • I kind of remember experiencing something like this with my Xbox 360 when I had it. Everyday it would seem I would have to update my game. It always appeared to be about a ~50Mb download each time. What makes you think that your PS4 is thinking you own the digital copy? Also, the tag updates is really not necessary.
    – Timmy Jim
    Commented Mar 14, 2017 at 18:13
  • You might have problems on you PS4's HDD. Is it only happening with CoD?
    – Kiogara
    Commented Mar 14, 2017 at 18:47
  • @Kiogara No today it happened with GTA V and Battlefield One .
    – Reflexive
    Commented Mar 14, 2017 at 20:18
  • @TimmyJim I don't beleive we have the same problem, as these are the complete updates for the game altogether. And one day (to confirm the ps4 thought I had the digital problem) the ps4 asked me if I would like to switch to the digital / disc version (can't remember) and I said yes, can't remember what happened then.
    – Reflexive
    Commented Mar 14, 2017 at 20:20
  • @ExperimentalRocket So it might be some malfunction with yours HD, it seems to be corrupting your files. Other than that might be how it handles low disk space, but I don't it'd delete files without your permission.
    – Kiogara
    Commented Mar 14, 2017 at 20:30

1 Answer 1


This sounds like an issue with the PS4 hard drive. You can try and correct the issue by rebuilding the PS4 Hard Drive. You can do this using the "Recovery Menu" and selecting Option 5: "Rebuild Database".

To access the PS4 Recovery Menu, you need to:

  1. Turn off the PlayStation 4 completely. Do not use in Stand-by / Rest mode.
  2. Once the PlayStation 4 is off, press and hold the power button. Release it after you’ve heard two beeps: one when you initially press, and another 7 seconds later.
  3. Connect the DualShock 4 controller with the provided USB cable and press the PS button on the controller.

You can read more about the process and watch the video here.

  • Ok. Also you should probably add that you can backup your hard drive with your computer so that someone doesn't mess something up and lose stuff.
    – Reflexive
    Commented Mar 21, 2017 at 12:35
  • 1
    Reinitialising the PS4 Hard Drive makes the backup useless. Only using the PS4 to make a backup would work.
    – Niraj Shah
    Commented Mar 21, 2017 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .