After an update my framerate dropped and I didn't know why. With measuring the GPU usage I found out that CS is using the wrong graphics. In my NVIDIA control panel I have set the global and the program settings to use NVIDIA. The only way I can force it to use NVIDIA is right-clicking on the .exe and selecting run with NVIDIA graphics processor. Please help me it doesn't happen with other games only with CS:GO.

EDIT: Now I kinda forced it to use the NVIDIA GPU by disabling intel power saving options but now my game is still lagging. Sometimes it runs like it should but when I click esc it goes back to laggy. My GPU is working(I think) and it's usage is about 50% please help me. When I play the game it is usually 60fps(used to be 130) and then it drops to 30 in couple of seconds. And I said I already did configure the program settings so stop sending this kind of replies.

Best Regards to the repliers, an aspiring CS:GO player

Instead of changing your global settings in nvidia drivers you have to change it for the particular game (in this case - CS:GO).
The gpu set in the Program Settings will override the global settings for that application, which is probably why you're having this issue in the first place.

Make sure you pick CS:GO from the drop down menu, or add the .exe manually with the Add button.

enter image description here

I just found the best solution and it helps me, just revert the setting of that game on nvidia GeForce experience. and everything is back to normal for me, and my csgo using my gpu now. and one more, try to disable multi-core rendering in the game, it makes my csgo faster, idk why. I Hope it help you

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.