0

Whenever I join a server or restart my CS CZ my key bindings for some reason are changed to God knows what.

Setting the config.cfg file to read-only didn't help. The same thing keeps on happening.

The only fix is to presently reinstall the game and rebind all the keys... which again after joining the game or restarting are changed.

1

There are a few things you can try:

  1. Change your key binds in your config while the game is not running and then set it to read-only.
  2. Change your settings in-game and set the config to read-only after you correctly shut the game down.
  3. Look for other config files overwriting your settings (autoexec.cfg, valve.rc, userconfig.cfg,...).
  4. Delete your cfg folder (or whereever you have them) and let the game create a fresh config and repeat steps 1 - 3.
2
  • have tried all these steps already... no matter how many times I start with a fresh file, or make it read only, the game keeps overwriting it – YaddyVirus Mar 20 '17 at 14:22
  • You could try creating a fresh config with a custom name. You can load it with exec filename.cfg if it's in the same folder as your other config. Just put it at the end of your old config file. Also, if you put an echo in it you can test if it worked. (echo hi will appear as hi in your console. This is extremey useful to track the order of loaded configs.) – dly Mar 20 '17 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.