0

I copied my Steam folder from my laptop to my PC in my attempts to try and get some of my games to work offline. I followed this answer in regards to editing the loginusers.vdf file but when I went to try and see if it worked Steam went to search for an updates, failing to connect to the internet and saying that Steam needed a network connection. correct me if I'm wrong but quite sure that's the opposite of being offline.

error

Before copying my Steam Folder I did boot up Steam just to make sure there were no updates pending for it so at the time of copying it it was up to date and I can't just connect my PC to the internet as it's too far away from the router for an Ethernet Cable (and there's ~6 years worth of Windows/Misc Program Updates since this PC has never been connected to the internet since I first got it).

So how can I stop Steam checking for updates for an offline machine?

  • 1
    I seem to recall the offline machine needs to connect at least once before it can be put into offline mode properly. Is it possible to connect it to the internet briefly to allow a one-off steam login? – JonK Mar 21 '17 at 22:49
  • @JonK well if i pulled apart my entire setup and move the PC and Monitor (it's plug isn't a VGA one) closer to the routers and tried to locate a spare keyboard and mouse then maybe but also there's no Anti-Virus on my PC (main reason is because it kept bitching about a program which altered Windows Libraries so i could customize the Start Menu more) and i'm not comfortable connecting a 6 year out of date PC to the internet without an anti-virus (all downloads are scanned on my laptop with an up-to-date anti-virus) – Memor-X Mar 21 '17 at 23:10
  • Afraid I can't help much in that case - good luck trying to find a way to do it though – JonK Mar 21 '17 at 23:59
4

There are a few small workarounds to get back your Offline mode after copying your Steam folder (if they didn't patch it out by now).

If you were online on Steam on your other machine you can change the offline computer's date-time to the time you were last online on the other one.

Also: If it worked, write down the time! Steam offline mode can expire and ask you to reconnect to the internet and changing the date again will "fix" this.


Another way to deal with it is described here This wants you to change the offline value from 1 to 0 in the steam/registry.vdf file.

The path of the registry setting is Registry / HKCU / Software / Valve / Steam / (Note, that this will turn off offline mode. You'll need to re-enable it and having a backup is very useful.)


And finally from this answer:

Create a steam.cfg file with the following content and put it in your Steam directory.

BootStrapperInhibitAll=enable
BootStrapperForceSelfUpdate = disable
ForceOfflineMode=enable
  • i think that might be patched as i changed the date time and it still gave me the error – Memor-X Mar 22 '17 at 10:57
  • There is another way described here. – dly Mar 22 '17 at 11:13
  • 1
    i checked that link and the post you talk about was made back in 2011. the only .vdf file i find that's close to registry is registrykeys.vdf. the registry keys it shows inside don't match to what the post say nor to they exists in regedit.exe (o checked both my offline and online machines) – Memor-X Mar 22 '17 at 11:30
  • I'll check it out when I'm back home. I'm pretty sure it still exists, but maybe somewhere else. – dly Mar 22 '17 at 11:33
  • gaming.stackexchange.com/questions/298284/… this steam.cfg approach could work as well. – dly Mar 22 '17 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.