Having started to higher rank weapons and armor, I'm looking to upgrade my arsenal. I've got a few rank 2 weapons researched and ready to develop (e.g. the Pathfinder Observer II), but when I try to develop them, the game insists on developing the rank 1 version instead.

Pathfinder Observer II, ready to craft: Setting up the Pathfinder Observer II for development

Hitting "CRAFT": Attempting to craft the Pathfinder Observer II

If I confirm the choice, the game really does craft the Observer I. I've developed one myself already, and also received one from the Deluxe version of the game. Both are sitting in my inventory, but I'd like a rank 2... Am I doing something wrong, or is this a bug in the game? (This is on the PC, if relevant.)

I've tried renaming the project to "Pathfinder Observer II" in case that did anything, but no dice. It creates an Observer I, called "Pathfinder Observer II".

I'm tempted to call this a bug, because if I craft the weapon as shown above, I get one with a rather useless clip size and max ammo:

Bugged Observer

If this is indeed a bug, and anyone's encountered this — is there a way around it? Or am I stuck with whatever weapons I can find?

Update: Seems like this only affects the Pathfinder weapons. I'm able to craft higher-rank weapons and armors, just not the Pathfinder weapons. I've tried doing this both on the Tempest and at the research center on Prodromos, but no luck.

  • 1
    This does look like a bug, I haven't experienced this issue
    – kalina
    Mar 25, 2017 at 23:07
  • @kalina That's what I'm afraid of... I'll try crafting somewhere other than the Tempest (where this is happening), but it'd be a real bummer if it stays this way. I'm not doing anything incorrectly though, right? Mar 25, 2017 at 23:09
  • luckily, most of the weapon shops rank up with your level, so you'll still be able to find higher rank weapons in the shops. The major downside to not being able to craft is not being able to add augments though, and some of them are quite good.
    – l I
    Mar 26, 2017 at 1:08

1 Answer 1


After some further searching online, looks like this may indeed be a bug. For some it appears that crafting a higher rank weapon produces the weapon with the wrong name but right stats, but not always. Seems to happen on PC, Xbox, and PS4. Hopefully it'll get fixed soon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .