4

I'm evaluating a Minecraft demo, but I'm facing a strange issue.

The games runs at a constant 60FPS which is fine. However, the game screen is split in two, from TopLeft to BottomRight (diagonal split). Each of the side of these lines renders with a few delay, and it leads to a strange behavior and make the game feeling a bit sick. This is especially visible when strafing, there are clearly two parts of the screen.

[Edit] Added a capture from a phone of the issue:

Minecraft glitch

Also a video capture :

At first I thought it was due to a v-sync issue, but I think v-sync issue are horizontal slit... not diagonal. Anyway, I tried with and without, even forces in the GPU settings.

If I take a screenshot, no glitch.

If I capture a video of playing (using fraps, 60imgs/s), no glitch too in the resulting video.

Any thoughts?

PS:

  • latest drivers have been installed
  • I'm playing on an Asus Zenbook Pro (Intel i76700HQ + 16Gb + Nvidia GTX960)
  • I've set up nvidia settings to enforce the GPU to be used (avoid optimus issue)
  • I've tried with vanilla MC and with Optifine (no difference)
  • Same issue with packaged java, and latest version of Java (tested both 32 and 64 bits)
  • My OS is Windows 10 pro (latest version, all possible updates)
  • No antivirus software when playing
  • Other games run without this issue
  • Minecraft windows 10 edition also performs with no issue
  • 2
    Is there anyway you take a picture with a camera/phone and upload? I'm really curious on what this looks like. – Timmy Jim Apr 4 '17 at 12:50
  • @TimmyJim I agree, this would be very helpful. – Julian Lachniet Apr 4 '17 at 12:58
  • I added a capture of the issue in the question (from a phone, the quality isn't great) – Steve B Apr 4 '17 at 13:40
  • I'm certain that it's monitor's fault. – Little Helper Apr 4 '17 at 14:04
  • @LittleHelper, this issue only occurs with this version of Minecraft (even the Windows 10 edition of MC works perfectly) – Steve B Apr 4 '17 at 14:19
0

After some tests, I finally discovered that something forces V-Sync whatever was set in the game. The clue was that the FPS was sticked to 60FPS.

Disabling it both ingame and in video drivers, disabled the option eventually (didn't know what was the exact option I disabled).

The FPS jump to a range between 140 and 200 FPS at max details (using optifine). In this case, the glitch disappears. However, I'm still eager to understand the behavior

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.