0

I tried to register with Steam on the following page for about 3 days now, and it doesn't work from Mac Chrome, Firefox and Safari. Am I the only one experiencing this behaviour?

https://store.steampowered.com/join/?

Maybe the JavaScript on this page is broken? I chose a username that has not been taken, and also entered all other information and clicked the I agree thingy. Please tell me if someone else can register or if there is another way to register with Steam (for example via some API, or PlayStation or something similar).

6
  • 2
    do you block cookies? did you try using the steam client? It also has a register function
    – Zommuter
    Commented Sep 17, 2011 at 12:20
  • 3
    Could you give more detail then just "it doesn't work"?
    – Wipqozn
    Commented Sep 17, 2011 at 12:38
  • sorry, -1 for your lack of detail and feedback. "it just doesn't work" is the worst kind of problem report I can imagine... If you edit in more information, please @notify me so I can take that back
    – Zommuter
    Commented Sep 18, 2011 at 10:09
  • 1
    Even nicer was that the Steam client told me my name was taken (as I had thought it would be), where the web rego claimed availability.
    – Stephen
    Commented Sep 18, 2011 at 11:04
  • 2
    Same issue that Stephen has. Now I'm pretty sure the website's backend that checks if the account name has already been taken is broken somehow.
    – Akku
    Commented Sep 18, 2011 at 13:16

1 Answer 1

3

Download and install Steam Client and register from there.

3
  • 2
    This worked. Just as information: the account name I chose wasn't free in the client (now chose another one), but the website showed me that it was free. Maybe it was an issue that the check for free-ness of the account name doesn't work correctly.
    – Akku
    Commented Sep 18, 2011 at 13:15
  • 9 years later and I got the same problem LOL.
    – Robo Robok
    Commented Jun 7, 2020 at 21:12
  • But now the app uses web form too, so it's not working properly in the app neither.
    – Robo Robok
    Commented Jun 7, 2020 at 21:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .