-2

When you run it in windowed mode it is tiny.

And when you run it in fullscreen mode, it crashes.

How can I run it at proper resolution without crashing?

3
  1. Make virtualbox windowed.
  2. Turn off "Auto-resize guest display" in the View menu.
  3. Resize your window to 4:3 and as big as possible.
  4. Turn on "Auto-resize guest display" in the View menu.
  5. Modify the shortcut to diablo.exe or (to PlugY.exe) to include these parameters: "-w -nofixaspect"
  6. Start the game using this shortcut
  7. Maximize the window
  8. Do not forget to set 800x600 in the game menu.

Not perfect, but still much better than native resolution:

Diablo 2 running in multiple windows

  • I'd suggest to install VirtualBox Guest Additions. These will enable proper screen resolutions and other things making your life much easier. – dly Apr 13 '17 at 6:51
  • They are installed, but the game crashes in fullscreen mode. – jsaak Apr 13 '17 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.