1

I installed FAR to play the game in borderless full screen mode, but it seems that my controller stopped being detected afterwards, and even after uninstalling the fix.

The controller (DS3 using SCP drivers) works fine in other games and is detected as Xinput controller in steam big picture mode.

I would love to hear about possible solutions from people who have experience with this type of issue.

5
  • Did you make sure all of the .ini changes laid out by the creator of FAR were done correctly? I found one possible fix, but it looks like the culprit was a mistake in the .ini configuration...
    – Vemonus
    Apr 18, 2017 at 3:07
  • @Vemonus I already checked the .ini file, but I haven't found an option that might be related to controller detection.
    – Kitegi
    Apr 18, 2017 at 12:19
  • hmm, let me post what I have and see if it helps then.
    – Vemonus
    Apr 18, 2017 at 12:40
  • 1
    @Vemonus I managed to fix the issue by going into Steam Big Picture mode -> settings -> Controller Settings, activating Generic Gamepad Configuration Support and restarting my pc. The game seems to work correctly now. Thank you for your help.
    – Kitegi
    Apr 18, 2017 at 14:39
  • so the first suggestion worked? Glad I could help!
    – Vemonus
    Apr 18, 2017 at 14:46

2 Answers 2

0

On the Steam discussion for FAR, it seems like someone else had a similar issue:

Do you know of a reason I can't use my controller with the fix? I remove the fix and my controller works add it back and it stops working. I am sure the issue is something I am not seeing in the ini.

The creator of the fix suggested the following:

Probably because the Steam client DLL is loaded early, which causes the new Steam Overlay features that have to do with gamepad input to hook in a different order than usual.

Run the game in Big Picture Mode and then check to see if you can configure your gamepad using Steam's new input functions.

While the user said this didn't help them, they followed up and said this solved their problem:

If anyone uses a Nvidia Shield Controller like I do for PC Gaming then you have to have this line set to false unfortunately. I am guessing Nvidia Bloatware is what is providing my system with the controller functionality. Make sense. Hope this helps.

DisableBloatWare_NVIDIA=true change to DisableBloatWare_NVIDIA=false

1
  • If this doesn't help, let me know and I'll keep searching!
    – Vemonus
    Apr 18, 2017 at 14:14
0

I opened up dxgi.ini and scrolled downed to [Input.XInput] and set Rehook=true and it seemed to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .