0

The enchantment table never offers any enchants for a diamond sword. I've enchanted countless other items. I often put in my diamond sword and see that there are no enchants available, then enchant a book to reset the enchantment seed, then put the sword in again, and still no enchants are available. This is in an enchanting table with the maximum number of bookshelves and at least level 30 experience.

Is there something wrong with my world, or is this normal? I don't see anything in the wiki that would suggest this behavior.

  • 1
    This is not normal. Make sure your sword has no enchants on it already. To be double sure, craft a brand new sword from diamonds and try that one. – Dan Bron Apr 20 '17 at 19:47
  • @DanBron Thanks, that was the issue. I was not aware that items with enchantments could not be enchanted via the enchanting table. If you state that as an answer, I will accept it. – hypehuman Apr 25 '17 at 23:56
1

Any tool can only be enchanted once. If the tool has been previously enchanted, or you have used an enchanted book on it in the anvil, then it can not be re-enchanted regardless of how much experience you have.

2

In addition to the Diamond Sword, you also need Lapis Lazulli (3) to enchant.

source

  • I'm not sure if I tried adding the lapis to the enchanting table with the diamond sword, but I know this is not necessary for other items. For other items I am able to see the offered enchantments when I add just the item itself, and I only need to add the lapis to actually apply the enchantment to the item. For the diamond sword, the offered enchantments are blank. – hypehuman Apr 19 '17 at 15:08
  • Take a look at the source material, it implies that for the diamond sword (and possibly other diamond items) you need the lapis to be present as opposed to other tools – Oak Apr 19 '17 at 15:31
  • Hm, I just tried placing the sword and the lapis in the table together, and it still doesn't offer any enchantments. Where do you see that implication? – hypehuman Apr 19 '17 at 21:39
0

As of 1.8, Lapis is a required part of Enchanting in Minecraft

Enchanting procedure

In order to enchant, the player needs an Enchantment Table, several Experience Points and the item they wish to enchant. As of 1.8 The Bountiful Update, Lapis Lazuli is required as well.

Note: this is the Lapis Lazuli Item, not the ore, or the block.

Additionally, you also require a minimum of 15 bookshelves, placed 1 block away from the Enchanting Table, to gain access to the tier 3 enchantments. If you do not have 15 bookshelves, you cannot enchant your equipment with tier 3, regardless of how much experience you have, or how much Lapis.

Finally, you need at least 30 levels of experience, to gain access to tier 3 enchantments. Successfully enchanting an item will cost experience, and could drop you below level 30, which will lock out access until you once again gain more experience.

So, to recap: To access tier 3 enchantments in the enchanting table, you need a minimum of

  • 15 bookshelves, placed 1 block away from the enchanting table
  • 3 Lapis
  • 30 levels of experience

If you do not meet all 3 of these requirements, you cannot access tier 3 enchantments.

  • I'm not sure exactly what you mean by access, but just to be clear, the lapis and the experience not required in order to see the available enchantments; they are only required to apply the enchantment to your item. – hypehuman Apr 25 '17 at 23:58
  • @hypehuman yes, that us what I mean. The enchantments are locked, or inaccessible to be applied, unless you have all of the requirements – Ben Apr 26 '17 at 0:02
  • I see. My problem is that the enchants were not available at all, not that I couldn't apply them. It turned out that it was due to the item already being enchanted (see comments on question). – hypehuman Apr 26 '17 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.