1

I recently got Skyrim Complete edition, the one with all the add-ons. I have it installed on my hard drive for Xbox360. I have many quests open, but the one I can't do is the Companions mission - Glory of the Dead.

I started the mission before, to kill the witches at the coven and get the heads. I have all the witches heads with me. I got back to Whiterun and saw Kodlak was dead. I then proceeded to the Silver Hand fort and wiped them all out. I then fast travelled back to Whiterun, where Vilkas said that the funeral will start and I must go to the Skyforge. I then proceeded up to the Skyforge, where Aela starts talking. They light Kodlaks body on fire, and that's it. Nothing. There was something said about the underforge, but the quest marker did not point there. It still says Attend Kodlak's funeral.

Now every time I go to Whiterun, the Skyforge has all the people there (the Jarl and steward, some villagers, and the companions) but they all just stand there. Vilkas, Farkas and Aela are all there. But the person not there is Eourland Grey-mane. I know he is needed, because you must give him the fragments of Wuurstal.

I have done more quests after this bug, even built a house by Lakeview. But every time I go to Whiterun the people just stand there, the pyre burning and nothing happens. I have gone to the stables and entered by foot. I have uninstalled the game and run it from disc. I have waited till evening and morning. I have slept. Waited there. Gone about my business. Even went back to the witches coven and the Silver Hand places. I just killed one lonely Silver Hand guy outside the fort, but nothing changed when I got to Whiterun.

Please has anybody solved this glitch for Xbox360? I want this mission done, so I can talk to those just standing there and continue the game, because I read that the Jarl is needed in order to progress the main quest-line

  • Do any of the bugs at elderscrolls.wikia.com/wiki/Glory_of_the_Dead#Bugs sound familiar? maybe one of them can give you a fix. Edit: this sounds like you visited the funeral late at night. Try revisiting it during the daytime. – Nzall Apr 19 '17 at 7:16
  • @Nzall i did read those before. i will try the suggestions about looking for Eurlond at his house. i have tried waiting as stated, but maybe i should go looking for him. i don't think the other members are missing. will comment tomorrow – Nicholas Aysen Apr 19 '17 at 8:56
  • 1
    Try a complete map reset. Go to a far away place, sleep for 30 days straight, and go back. This completely resets the area and hopefully gets people to the right place. – Nelson Apr 19 '17 at 12:30
  • @Nelson will try this also. I have a task at Malkreath(?) and that should be far away enough. i'm sure there's a bed in one of those houses of people that are gone to meet their makers. – Nicholas Aysen Apr 19 '17 at 12:48
  • You don't need to "sleep" sleep, just stand there and wait for 30 days (not 30 hours. Days. 30 x 24 hours.) – Nelson Apr 19 '17 at 14:09
2

NOTE

I have just written out this entire answer then learned it may be possible to get your save up and running in Skyrim for PC where it could be debugged properly. I'm unsure how likely this is to work in reality but I would be more than happy to point you to an article that explains how to extract your save and I'd be happy to attempt to examine it on PC for you. Never-the-less it's a long shot so here's my original answer.


I just wanted to provide a concrete answer here of what I think you're already aware of; without a save from just prior to returning to Whiterun there's nothing to be done.

I've spent a while looking for this bug but cannot find it, and I never experienced it myself on PC - it's likely XB360 only.

Going forward always bear in mind that the Creation Engine - upon which Skyrim is built - is prone to such bugs. In a more linear game this bug would probably have been found by the developers but due to the complexity of in-game story branches in Skyrim (and all TES titles) it's almost impossible to test for all eventualities.

I know it's frustrating but going forward there are things that you can do:

  • Save, save and save some more. I tend to have three or four saves per play through, on top of the standard auto saves. Make the saves at regular intervals and before making big decisions.
  • Did I mention save? When saving if you overwrite a previous save only do so if you're happy that there were no problems since then. For example if you made a save right after destroying the silver hand and before returning to Whiterun then went to save again at the Skyforge I would NOT overwrite as I know that save may not have the buggy event that caused Euorland to disappear which means you may be able to do something differently to skip the bug.
  • Check the quest journal and markers. Even if you role play a realistic play through without using UI like a compass and markers if you think something may be amiss check the journal; has a/the quest appeared/disappeared? Has an objective updated? Are there any quest markers on the map (almost every quest objective has a marker)? If not this is a sign there's something wrong - make a new save and don't overwrite any previous saves and try to confirm there is a bug. If so, revert your save and try something different, perhaps Google the bug - if someone else has seen it there's likely already a solution if you have a pre-bug save.
  • Don't rush. The Creation Engine is old and running on old tech like the XB360 can make it run unexpectedly slow in the background. As such try not to rush it as it could skip certain stages of processes. For example if you complete a quest and expect a reward that didn't appear straight away, wait for it - even for a few minutes, this does happen. If not a quick reload of a save from before you turned in the quest will likely solve it. The worst thing to do here is start new quests or run off to another cell (city, house, save etc.) - this could make the game forget what it was doing.
  • Don't do too much at once. Try to keep the number of quests in your journal to a minimum, especially related ones. The more quests you have active the more chance there is of conflicts. If you're unsure check for the quest over on the UESP Skyrim Quests page and look for bugs (bottom of the page) - there may be a spoiler or two but it's worth it if it keeps the game working.

I know that's an awful lot to do when you expect the game to just work but the shear size and complexity is the main cause of your problems. The main thing is Saving before you do something that could have a bug. I'm unsure how many saves the XB360 can hold but I would use as many as possible and only overwrite when you're certain that there has been a save since then without any problems in it.

Best of luck with your adventures - I really am sorry that we're unable to help rescue this save.

  • 1
    thanks very much. i realise that having so many quests open is a nightmare, both logistically and in-game performance wise. i try to group them together and only go to new towns/areas if i have to. but i still get swampped and am trying to cut down on active quests. i have a hardrive that i can push the save games to so that's not a problem. as things stand, i'm still playing through, and if there is a point where i really can't continue, i wouldn't mind too much restarting, knowing more etc. i will look into that article and let you know – Nicholas Aysen May 11 '17 at 10:46
  • 1
    i just hope the quest is not beyond some point of resolution, should the article's advice work. i have got some buddies that might still have skyrim on PC, so holding thumbs i can get this sorted – Nicholas Aysen May 11 '17 at 10:47
  • 1
    @NicholasAysen I think if you can get this working on PC I would suggest just using the command setstage C06 20 if you can't locate Eurlond to skip to the part where you must go to the underforge. – Kallum Tanton May 11 '17 at 10:55
  • how do i send you a pm? – Nicholas Aysen May 15 '17 at 12:28
  • @NicholasAysen I just created a new chat room called "Skyrim Save Game Platform Migration". If you'd rather private message I can make my email available – Kallum Tanton May 15 '17 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.