For example: Space (jump) + WASD (move) and R (Sprint). In this case I can sprint, but I can't jump at the same time.

But if I try Space + WASD + another key like F it does work.

I have a Sharkoon Skiller Pro (it is made for gaming), and sticky keys are off.

PS: This is annoying in games like Minecraft.

  • Does it only not work for Minecraft, or are there other games you've tested with? Also, do they work in a text editor?
    – Oak
    Apr 22, 2017 at 14:00
  • Are you holding R while sprinting?
    – Ben
    Apr 23, 2017 at 22:59
  • Related, if not duplicate
    – Ben
    Apr 23, 2017 at 23:01
  • I can confirm that this is not a general keyboard problem because I have the same keyboard. Maybe you should update you drivers?
    – BRHSM
    Apr 24, 2017 at 6:55
  • 4
    Possible duplicate of How do I remove the limit on PC keyboard button presses?
    – pppery
    May 5, 2021 at 3:30

3 Answers 3


The Skiller Pro appears to have multi-key rollover, as opposed to N-key rollover. This means that certain key combinations are impossible to press together at the same time. (For example, my laptop keyboard cannot press CYOM pr WAS at the same time.) It appears that this may be the case for your keyboard with W/A/S/D + Space + R.

To test this, open notepad and hold down all of those keys. If one of the keys can't be recognised, it means your keyboard is not capable of handling that combination. For instance, if I hold W, then A, then D, without letting go of any of them, I get something like WWAAAAAAAAAAAAAAA - note the absence of a D.


Three things I can think of: (1) you have a conflicting keybind preventing R from activating sprint properly, or (2) your keyboard simply doesn't allow all those keys to be pressed at the same time, or (3) drivers.

(1) Check Options > Controls and look at the sprint keybind. If it is white then you have no conflicts (unless you're playing with mods and a mod's keybinds are in another menu). If it is orange or red then there is another action also bound to R. You'll have to remove one of them for the other to function correctly.

(2) Try a different keyboard.

(3) Since you have a keyboard designed for gaming it's possible that you need to install special software or drivers. Many driver updater and installation "assistants" are simply adware/malware, so be sure to get the drivers from an included CD or the manufacturer's website. Head to a reputable tech site like HowToGeek if you need help installing them.

If none of those worked, you'll need to use a different key (or mouse button if you have spares) for sprint, or go old-school and simply double-tap W.


In older versions of minecraft there was a feature where r would enable cinematic mode where the cursor had momentum and acceleration. And your keybind may be conflicting with the other one? You could try changing the keybind to something like c or the default ctrl. If this is not the issue then I cannot be sure as to what it is with the information I have.

Not the answer you're looking for? Browse other questions tagged .