This is great:

@java -Xms512m -Xmx1024 -cp "%APPDATA%/.minecraft/bin/*" \
    -Djava.library.path="%APPDATA%/.minecraft/bin/natives" \
    net.minecraft.client.Minecraft %IGN%

But if your trying to use any HD texture pack you will get the "unpatched bug" i.e. small lava and portal textures on all dirt blocks

is there any way to fix the issue ?

1 Answer 1


That command line allows Minecraft to use extra memory and use an "offline" player name, but does not itself fix any problems with HD textures. Make sure you have the correct mod installed.

Update: I think I just figured out what's going on. That command pulls in all the .jar files in your .minecraft/bin folder. Well, it happens that the patcher used by the HD textures fix creates a backup of your original, unmodified minecraft.jar file in that same folder, which I suspect is conflicting with and overriding your mods.

Find that backup file (it should be minecraft-1.8.1.jar if you're using the latest version) and move it somewhere else (or just delete it). I expect that will get things working again.

  • That "script" starts a cmd which allows you to state an IGN= ingame name when mincraft auth servers are down this allwos you to play "offline" but with a Real name in smp . "or for the more cheap cheeky little people to play without paying" My question was allthough this works if your using the HD texture packs you will recive the "unpatched bug" i.e. small lava and portal textures on all dirt blocks This "play offline.bat" does not access the patched minecraft.jar thus no MC-patcher FIX Any one have some ideas ps: bought mine in beta :P
    – Garble
    Commented Sep 21, 2011 at 11:29
  • It does access the patched minecraft.jar. It sets the class path with -cp "%APPDATA%/.minecraft/bin/*" That is the directory where the minecraft.jar resides (patched or not). Then it runs the net.minecraft.client.Minecraft class which exists only in the minecraft.jar. I did a quick look at the MC-patch and it does not edit this class, so my assumption is this should fully work. Can you verify you did in fact install the patch to the "%APPDATA%/.minecraft/bin/minecraft.jar" file? Commented Sep 21, 2011 at 14:18
  • indeed i did but it still happens Thats why i decided to sign up here as this is where i found the "script"
    – Garble
    Commented Sep 22, 2011 at 21:09
  • @Garble — I think I've got it. Updated my answer.
    – Ben Blank
    Commented Sep 23, 2011 at 0:30
  • still no joy removed 1.8.1jar both in admin and user allso tried to patch the admin install no luck wonder what it is
    – Garble
    Commented Sep 23, 2011 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .