I just bought the game Civilization V on the AppStore (Apple) : The game seems to work but there is no text on any button, title, text field, etc. Is there a way to fix this ?

Tech info :

  • MacBookPro Intel Core Duo 2,33Ghz / 4Go
  • Snow Leopard
  • Radeon X1600

enter image description here

EDIT : I managed to start a game trying to figure out where was the correct buttons to click on, and actually the game runs, but there are huge display problems... I think that the Radeon X1600 is not supported...

EDIT 2 : I've added this in-game screenshot to explain the fact that this doesn't seems to be only a font problem :

enter image description here

As your see, the background is still the one of the intro (the current landscape is not drawn). The moving icons are buggy, etc.

  • Have you tried updating it? Looks like a language translation problem. You trying to play in a different language than english? – Neil Sep 22 '11 at 10:55
  • In fact, the settings of the game are in french. I know it because the intro trailer with the old man is in french. So everything is perfect for me. Except that the texts are not displayed. – Pierre Watelet Sep 22 '11 at 11:18
  • This is a font issue, 100%. Sometimes Mac's built-in fonts are not compatible with "standard" fonts. That being said, I have no idea how to fix it. Do you have the French language font packs installed? – Satanicpuppy Sep 22 '11 at 14:11
  • @Satanic Puppy : I've added a screenshot to show you the extend of this problem... – Pierre Watelet Sep 22 '11 at 14:36
  • Have you tried different video drivers? – Matthew Read Sep 22 '11 at 15:42

In windows this game had its own font but sadly named same as a standard font, so text would be wrong size and hard to read. Solution to that was to find the font and download it to overwrite the standard font. Maybe it is similar thing for Mac?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.