2

I'm having trouble with Terraria after moving from mobile to desktop (Linux, GOG version). The biggest issue is pausing it. I've read up on autopause and can pause the game (with some hassle)... but it keeps chewing CPU and burning battery while paused.

Even when minimized or switched to another workspace.

Tested: XFCE4, Gnome3/Wayland, Gnome3/Xorg. All on Fedora 25.

CTRL-z when started from a terminal works but when I "fg" it to resume it sometimes becomes unstable or crashes with "Not enough memory". It looks like it has set tons of timers which it can't cope with when it receives them all at once. This happens even when the game is (auto)paused first, maybe because the graphics keep running?

So, for Windows users, if you background the game (minimize it) in single player, does it keep running with lots of CPU used in Task Manager?

I'd love to be able to pause the game with a simple "pause" key and have it just ... stop. Stop rendering torches and backrounds etc. Stop running background threads. Wait until woken.

Given the age of the game, feature additions seem unlikely. So does anyone have workarounds? Is this an issue on Windows too and people just don't care? Or is it a Linux specific issue?

I'd like to be able to play this for a while then go unplug my laptop, do something else, and come back to it later without losing all my state and having to reload. Especially since I can't always wait for a convenient time to stop playing (kids, starting work, etc).

  • Have you tried different ways of pausing, like Alt+Tab? – Riftcaster Jun 11 '17 at 10:40
  • @Riftcaster Yep. Alt-tab or manual minimise. Windowed or fullscreen. Seems to make no difference. Wondering if it's a defect in the Linux version. But so far nobody's actually checked in Task Manager on the Windows version to see if it hogs CPU there too (and everyone just thinks that's OK) or if this is abnormal. – Craig Ringer Jun 11 '17 at 12:44
4

As far as I know, even on the Windows version, Terraria does not "stop" rendering. Entities (enemies, NPCs, the player) don't move, but particles (such as sparks from torches) keep going, up to some maximum. I've tested this in the past by alt-tabbing out of the game (thus pausing it), then hovering my mouse over the game's icon in the Windows task bar, which brings up a preview of the game screen. In the preview, I could see a bunch of sparks being generated around torches but not falling. When I went back into the game, the sparks all fell at once.

I suspect that the pause feature is implemented with a "stop all important game entities from moving"-type logic. Particles aren't important in a game-playing sense, so they probably get through the filter. This is speculation, though.

Despite the game's age, it's actually still being developed, with new features being added every now and then. I think a new content patch will happen in a few months, actually. You might be able to get a response on the official Terraria forums if you post in the PC Support section.

0

I don't play terraria for a long time, but I remember that it had a Autopause button somewhere in the options menu. Have you tried that?

Is located right here:

Image Autopause

See if that solves your problem when exiting the game, I don't know the current version you're playing so I'm expecting the newest version.

  • I don't think this is quite what the asker is looking for in an answer. From the sound of their question, it seems they know about this already. – Timmy Jim Jun 12 '17 at 16:27
  • I was quite specific that I was not looking for autopause, and that the issue is that it's keeping on running in the background burning cpu (and my battery) even when autopause'd. – Craig Ringer Jun 13 '17 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.