0

I have two different problems that are most likely related:

1 - Null Pointer Exception on Multiplayer

I've been playing Minecraft for around 3.5 years now, but this is the first time I've experienced this error (I've dealt with and solved numerous others). For MC 1.11.2 and below (unmodded), multiplayer works perfectly fine. However, MC 1.12 and MC 1.11.2 Optifine multiplayer does not work. The same error occurs for every server I try to join. The error is as follows:

15:32:56    bkp Connecting to mc.hypixel.net., 25565  
15:32:56    bkp Couldn't connect to server
java.lang.NullPointerException: group  
    at io.netty.bootstrap.AbstractBootstrap.group(AbstractBootstrap.java:84)  
    at gw.a(SourceFile:276)  
    at bkp$1.run(SourceFile:59)

I have: uninstalled all outdated Java versions, updated Java, allowed all Java processes in Windows Firewall, reset the ".minecraft" file, reset network adapter twice, logged out and logged into Minecraft multiple times, done some stupid internet rituals that include trying over and over and joining servers slower, uninstalled McAfee and Avast! (they had already been uninstalled, I checked), and restarted my computer after each of these methods. Nothing is working, and since 1.12 came out, I can't join any 1.12 servers. Are there any methods I may have missed? I have F-Secure Safe and Qustodio, neither of which SEEM to be causing any problems.

2 - Singleplayer crash when loading world

Minecraft single player does not work either, not in MC 1.11.2 or in MC 1.12 (I have not tested other versions). I can create or join a world, the game output shows no errors, the world loads to about 97%, then the game freezes and eventually crashes. This may be related to problem #1, but it is not as urgent, as I typically play on multiplayer anyways.

I have searched and troubleshooted from results on Google for around a total of 8 hours for two days, but nobody seems to have my exact problem. I need help.

-1

I have had this issue before. I fixed it by uninstalling any programs that I thought were interfering, such as anti-viruses and what probably made the difference, something called Questido, which was an app my parents used to restrict my computer like 4 years ago.

protected by Community Jun 29 '17 at 0:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.