-4

I am trying to download Minecraft 1.12 but as soon as it starts up and the launcher disappears, it crashes. I tried with a few other snapshots for 1.12 as well. Here is the crash report:

Exception in thread "main" java.lang.UnsupportedClassVersionError: net/minecraft/client/main/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
2
  • Have you tried anything to resolve it yourself? Even performing a Google search could turn up better results
    – GipsyD
    Jun 13, 2017 at 19:41
  • maybe just update your java...
    – Serverfrog
    Jun 13, 2017 at 19:55

2 Answers 2

1

Mac is installing Java to a new location, which Minecraft doesn't update. In order to update the location, you need to do the following:

Click Edit Profile > Java Settings, Check Executable, and set the path to this:

/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java

From Information coming from another post, the issue might be different for older Macs.

0

It seems it can't access some Java classes. I think you are still on Java 7. Try updating to Java 8 as thats required by Minecraft since the 1.12 update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .