4

Since it was merged with MESS, I guess MAME should emulate all those systems, ColecoVision included. But emulating this seems like an impossible task for me. Despite my best efforts, nothing was enough.

So far, I have:

  • MAME64 running on Windows 10.
  • A "rom" folder inside of the mame root.
  • A subfolder "coleco", where roms are stored.

The path to my ROM files is mameroot > rom > coleco

MAME is launched from a front-end (Attract-Mode). The command line I'm using on Attract-Mode is "coleco -cart [romfilename]", all paths are ok. But when I try to run any CV game, the output is "313 10031-4005 73108a.u2 NOT FOUND (tried in coleco coleco)".

The 313 10031-4005 73108a.u2 file is everywhere: mame root, rom, coleco. But MAME keeps saying it's not found. What is wrong? Can anybody who has CV games running on MAME show me what the problem is?

  • 1
    Given the error it seams it's looking in /coleco/coleco/ folder. try this way. – Иво Недев Jun 15 '17 at 6:04
  • 1
    I tried it too, no luck. But since my roms folder was "rom", MAME wasn't able to find the games. I changed "rom" to "roms" and everything is ok now. Weirdly, it happens only with Coleco; CPS2 was configured as "rom" with no issues. – Daniel Lemes Jun 16 '17 at 20:42
1

Check the directory where your mame64.exe is located; there's probably a mame.ini file in there that should tell you which rompath mame64 is using. Note that it uses that path starting from the directory you're in when you launch mame64, which may not be the directory mame64.exe is actually in. It depends a bit on how your front-end handles that. You could use absolute paths in the mame.ini to prevent issues here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.