1

I have an Intel integrated graphics card (HD 530) and I am having issues with different games in my Linux (Fedora 25):

  1. In Vampire the Masquerade: Bloodlines, the loading screen is glitched and the game crashes a few seconds after loading:

Glitched loading screen in VtM: Bloodlines

  1. In Mount & Blade, I have an error after the introduction video:

Mount & Blade error message

(Error message: "Unable to open texture file Textures\font.dds", even though the file does exist)

  1. In The Stanley Parable, the initial game screen is odd and there are several missing textures in the game, and it crashes after a few minutes at best:

Glitched The Stanley Parable intro screen

In all games, I tried setting textures and settings to minimum, changing video modes, updating graphics driver, etc, but nothing worked.

The only similarities between them are that games 1 and 3 both use the Source engine (albeit with 7 years between them), and games 1 and 2 use Wine.

How can I fix it and play the games?

  • Use an actual video card? You can't expect an integrated card to play 3d games. – Frank Jun 15 '17 at 21:58
  • 1
    I can (and I do), especially for games that are over 10 years old (or where the graphics do not matter, as in The Stanley Parable). As you noticed, this was a Q&A to help others; all the games mentioned are able to run on an integrated card, and requiring people to buy graphics cards for such $5 games is a bit excessive. – anol Jun 16 '17 at 7:49
4

The solution turned out to be simpler than I expected: installing libtxc_dxtn.i686 (the 32-bit version, to be exact), a texture-related package, solved all issues in the 3 games:

sudo dnf install libtxc_dxtn.i686

It turns out that the issues were related to compressed textures - S3TC, to be more exact - and, for some reason, that package was never suggested when I installed Wine, neither when I installed Intel's graphics stack recipe.

Looking for the errors in each game in an isolated fashion didn't help me; I spent about a dozen hours trying to find out the cause. I accidentally stumbled upon a page mentioning driconf, and another mentioning libtxc, but they were drowned in other pages with unrelated errors (mostly for Windows players).

In hopes this answer will help others save time (adding the images and game names to this well-indexed site should help)...

Note: the issue seems quite obvious once you know textures are the cause, but it was not obvious at all at the time, especially in isolation (for instance, the Mount & Blade error message seemed more closely related to filepath issues in Linux than with the loading of textures itself; also, texture errors in principle should lead to visual artifacts, but not crashes). I would have immensely appreciated finding an answer on SO. Please take that into account before considering this Q&A off-topic, or trivial.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.