Why is it so difficult to connect to online Horde and Beast modes?

I read somewhere that the servers had been having issues over the weekend but I tried again last night and I still get the same message displayed "No suitable matches found". I also read that you can't join a match that is in progress, i.e. you can only join at the start of a game. But considering there are thousands of people on line, surely I should be able to connect.

  • I have exactly the same problem. And sometimes if im finaly connected I am alone in a game after the loading screen. Wtf!
    – user12895
    Commented Oct 3, 2011 at 20:59
  • It hasn't improved at all after the server problems they had. I have only managed to get in to 2 horde games in the last 2 weeks.
    – Purplegoth
    Commented Oct 4, 2011 at 12:21
  • I can't connect at all in 5 days, even after leaving open for 15+ minutes!,,,
    – user12981
    Commented Oct 7, 2011 at 1:55

2 Answers 2


I don't know why it's happening, but I've found that if I back out once the game has begun trying to connect me to one of the 20 matches it initially finds, I'm able to get into a game once I try again.

It may be blind luck, but ... it's seemed to consistently work (and if nothing else, it's better than just sitting about).

I've also found that people bail rather quickly from games. I finally got into a horde game where we had 4 people going into waves in the 30s, but it didn't last much beyond that.

Because of that, and that people may be focused on versus at this point, it might be worthwhile finding a group of people to play with on a Web site, or waiting until more people have started playing horde and beast modes. I know that's what I'm planning on doing this weekend.


well when im searching for a game its maybes a maximum of 2-3 mins to set the game up, im thinking that you are all suffering with a moderate/strict nat type?

when you are on the game set up screen (horde/beast etc etc) unless your nat type says open you are gonna struggle to get a game first time.....

to change your nat type simply press the middle button on pad, right to system settings and check your connection status i.e do a connection test, this will reset the nat type to open!very simple

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .