So I got off MC to go to bed and I got back on this morning. I was inside my 3 story house. I spawned in a hole. I thought "Lag maybe?" I hopped out and saw my furnaces and crafting table were cut off. I looked back at the hole and its exactly where my house should be. No, I didn't explore at all actually. It was 20 blocks from where i spawned. I spent a lot of time on that house. Please help! (I tried to get an image but i can't figure it out XD)


Like others have said, you might have not saved your world before leaving. If you left your computer on all night, it's most likely a glitch, otherwise, I have no idea what it would be.

To get an image, press F2 while in the game and on the world, which will take a screenshot. If you're on Windows, close your game window and press the Windows button on your keyboard + R once you have closed the previous window. Once you get the pop-up, type in "%appdata%" and then press enter. Once you have that up, scroll down the list until you find the file named ".minecraft" and double click it. When the pop-up once again shows up, find another file labeled "screenshots" and open that. Scroll all the way down until you reach the final image contained inside that file and double click it. In the top right corner of the pop-up that comes up, there should be a "save" button. Click that, and then open a new browser and go to imgur.com. Once there, find the button in the top left corner that says "Upload" Click on that, and follow all of the instructions until it's complete. Finally, copy the link given to you and paste it into here.

This next idea probably won't help get your house back, but you could try creating a copy of the world - Go back to main menu, go into Singleplayer, find your world, click on it ONCE, and find the button that says edit located at the bottom of your screen. Click on that and find the next button that says "Create Copy of World" (or something like that) and then you can go into that world and see if you can find your house. This worked once for me, but it might not work. Hope this all helps!


It's a chunk glitch per say, did you played on a new (or old?) version of minecraft? Did you saved it before quitting? (sometimes a world is not saved if you didn't wait it to save and quit you back to the title screen), Did you encountered a problem while saving the world? The world might be corrupted.

(i experienced this too back when i played demo, a 16x16 chunk was gone, which where my house was, too bad i guess?)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.