0

How do you get in-touch with Blizzard directly from within Australia?

I'm trying to have the authenticator removed from my account. I've submitted a ticket for it with the ID scan they've requested. Now a GM has replied to this ticket, but I can't view the ticket, because it asks me to login to view it – which I can't do – because of the authenticator.

I've seen many other people complaining about the same issue and yet the issue still persists.

  • 1
    The website should offer you to call their support line, after you meet the criteria for it, offer to call only happens while their call center is open – Ramhound Jul 12 '17 at 3:11
  • 1
    I've called their call centre here in Australia, but all you get is an answering machine that tells you to go back to the website support page. I don't get why the downvotes either, because the process simply does not work on their website... – adamj Jul 12 '17 at 6:23
  • Also, you are given 3 options to contact them: web ticket, phone and live chat. For Australia, phone goes to a machine which tells you to go back to the website for support, so that one is out. You can submit a web ticket, but you cannot reply to a response from Blizzard, since you can't login. That leaves you with the live chat option, which also requires you to login, so no go there either. – adamj Jul 12 '17 at 6:43
  • Start here us.battle.net/account/support/login-support.html?ref=https://… - same result? – dly Jul 12 '17 at 6:55
  • @dly That's where I've already been and submitted my ticket. But you cannot reply to these tickets, because it asks you to login (i.e. us.battle.net/support/case/detail/83483838), which I cannot do due to the authenticator I'm trying to have removed. – adamj Jul 12 '17 at 7:03
4

You do not need to be logged in to open a support chat. I've just tried.

Go to chat once it's open for your location, click the corresponding button when it asks you to log in (preferably "I don't know my e-mail") and you can upload your ID again. After that you'll be asked to provide as much account info as possible - done, a chat window will pop up.

enter image description here

  • "Now a GM has replied to this ticket, but I can't view the ticket, because it asks me to login to view it – which I can't do – because of the authenticator." The message you receive is an automated message coming from noreply@blizzard.com, which means you can't reply to the email address either, as no one checks it – adamj Jul 12 '17 at 6:24
  • may be different for Europeans... I'm in Australia mate. The email contains a reply of the GM with a link to the support ticket. When you click on the link to view the ticket to be able to reply to the GM it asks you to login after which it asks you for the authenticator code – adamj Jul 12 '17 at 6:36
  • @adamj "may" .. I don't know if they're even different or changed it globally. Also try to log in to the support area from the front page (and click "can't log in"). This was more helpful for me in the past. – dly Jul 12 '17 at 6:46
  • See my latest comment at the top, most of what you said is a not possible. You cannot login without the authenticator code, which means you cannot access any support from them whether it be web tickets or live chat. Phone support for Australia does not exist. – adamj Jul 12 '17 at 6:48
  • 2
    Thanks man, but I've sorted it out by creating a new account and talking to them through that. I've let them know about this issue and they've confirmed it, so hopefully in the future no one is going to suffer through this nonsense. In-regards to the above, that's pretty convoluded. People would never know this option exists unless they've forgotten their account email address. – adamj Jul 12 '17 at 10:37
1

For Australians, the only reasonable solution for this big problem is to create a temporary account, which you can then use to speak to Blizzard directly to rectify things.

Anything else is just complete and utter waste of time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.