I can't allocate more than Xms1G into Minecraft. I've looked at every tutorial and still, I can not allocate more. I have 8gb of ram and a 64-bit operating system. How can I allocate more? I've tried putting Xmx-4G but it crashes and says something about my Java Virtual Machine.

  • This isn't a bad question, but one thing you could add is what you have tried so the answers are not repetitive. Jul 15 '17 at 19:54
  • Edit to my question (commenting so you don't miss it): You also need to have "Advanced options" active in the "Launch options" menu. Jul 15 '17 at 20:47
  • And a second edit: You have to click on the three lines at the top right to get to the four tabs. Sorry, I forgot that was necessary, because it's always expanded for me when I start the launcher (because I did it before). Jul 15 '17 at 20:49

This works for me:

  1. Open your minecraft launcher
  2. Go to launch options
  3. Make a new profile
  4. click on java executable (little switch)
  5. Click on JVM arguments
  6. Write -Xmx4G

Thanks :)


In the launcher, there are four tabs at the top. The right one has profiles, there you can select the profile you want to change. It should have a text box labeled "Java arguments" or similar. There you can enter it, save and (back on the first tab) play with that profile.

The tutorials you saw probably were for the old launcher, there the procedure was a bit different.

Next time you're asking a question on Stack Exchange, please give more details to why your attempted solution didn't work. Now I had to guess.

Keep in mind that setting the allocated RAM higher usually makes the game lag less, but at some point it can create lag spikes every few seconds. Try experimenting with different values between 1GB and your maximum if you experience that.

And finally: I think the Java argument for overall RAM allocation is Xmx, but I'm not sure.

Edit: First you have to activate "Advanced settings" in the "launch options" menu (before selecting the profile).

Edit 2: To even get the four tabs, you have to click on the three lines in the top right.

Not the answer you're looking for? Browse other questions tagged or ask your own question.