I have connected the Nintendo Switch to a 16:10 monitor (EIZO FlexScan SX2262W). The monitor's native resolution is 1920 by 1200, but I have tested that it also accepts 1080p input.

In the resolution settings, the Switch offers only “automatic” and “480p”. 480p does not work at all (which is ok) and with the automatic setting the Switch chooses 1920x1200 and stretches the image to that resolution, not preserving aspect ratio.

Is this a problem that the Switch has with all 1920x1200 monitors, or is it just mine? Is there any workaround?

(My Switch works just fine with Full HD monitors, and the Wii U worked fine with my monitor, as do other devices.)

Update: Since the question has been bumped and I am still interested in this, I will report that a recent update (4.0.0, I think) has changed the situation, but not resolved the problem. The Switch still only shows 480p as available and now, instead of outputting stretched 1920x1200, it actually outputs 480p, which leaves me with a tiny image (with correct aspect ratio) in the center of my monitor. It is kind of hilarious.

Second Update: It remains funny. Now (5.0) I get 1680x1050 (I think, I would have to check again. Slightly fewer than 1050 lines and wrong aspect ratio, that I remember). With a cheap HDMI->HDMI+TOSLINK splitter in between I get 720p, which is obviously suboptimal, but good enough for me to play Splatoon.

  • 2
    Make sure its not your monitor doing the stretching, as by default it will stretch anything that's not 1920x1200 to fill the screen. Check that the Screen Size setting is set to either "Enlarged" (scale, but keep aspect ratio) or "Normal" (don't scale). If its set to "Full", the default setting, then it will stretch to fill the screen.
    – user86571
    Commented Jul 17, 2017 at 3:31
  • 1
    @RossRidge, thanks, the monitor shows that it get a 1920x1200 signal, so there is nothing for it to stretch.
    – Carsten S
    Commented Jul 17, 2017 at 5:51
  • I'm getting this with an OG Switch connected to a Lenovo T24d-10. Interestingly the monitor reports 1080p connection but is stretching the image to 1200 high, and its scaling menu is disabled. Same results when outputting 1080p from Mac. But outputting 1080p from Windows results in the correct letterboxed image. Bizarre. Commented Sep 28, 2023 at 9:42

2 Answers 2


This was a well known issue that was repeatedly reported to Nintendo on their official forums among other places and a variety of fixes have been released targeting the problem.

The problem was specific to when using the Nintendo Switch plugged into a monitor rather than a television and does not specifically impact monitors with non-16:9 resolutions as many of the monitors reported were 1920x1080 panels.

The latest version of the system software should have resolved most of the issues, if not you might want to try a different HDMI cable as many people who experienced the problem at the time found that in some instances simply using a different cable was enough (although some people ended up using an adaptor from HDMI to DVI or VGA to resolve their issues).

  • Think you gor your answer which provides an interesting link. It made me curious, so I rechecked, but with 9.0.1 the situation is the same as what I have described for 5.0.
    – Carsten S
    Commented Nov 23, 2019 at 10:33

Unfortunately, I don't have a work around, but it appears that this is a problem with some 16:10 monitors.

This happened to people with the Nintendo Wii before, where some 16:10 monitors detect a non-HD source, and stretch the extra 11.1%, which is most likely the problem you are facing. You could read more about this from here:


Although I realize that both screens are at 1920 X 1200, it may just be an input problem with the monitor, which is something that I currently do not know a workaround for.

Hope that helps!

  • 4
    Thank you, but I do not see how this could answer my question. Not only is it not about the Switch, the situation seems very different as my monitor reports a 1920x1200 signal, so it is not stretching anything, the Switch is.
    – Carsten S
    Commented Jul 24, 2017 at 10:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .