2

I've been playing a Elite Dangerous over the past few days. Now today, when I start up steam, it suddenly says it is uninstalled (name in sidebar is dimmed, and play button is replaced with install button). To check, I took a look at CCleaner's uninstall tab and it said Elite Dangerous was there: 24.9 GB of space.

I was thinking maybe just to install it again, maybe it will just install specific files that somehow got lost, but I don't have 24.9 gigabytes of space left on my computer, so it won't let me.

I'd rather not have to install it all over again, as it would take around 8 hours.

I have tried restarting my computer and steam.

What's happened?

EDIT: I am able to launch it from running EDLaunch.exe in the Elite Dangerous folder in steamapps/common, so it is purely a steam issue. But I'd like not have to do this everytime...

  • 1
    Depending on the game, I think when you choose to download and install it to the directory it already exists in Steam realizes the files are already there and skips most of the download. You may want to try that first if you think the game is still installed on your disk. – Malco Aug 3 '17 at 16:46
  • @Malco I was thinking of doing that, but it won't let me because I do not have enough space on my computer (I only have about 11 GB left :/) – MCMastery Aug 3 '17 at 16:47
  • In the long run, 8 hours isn't that much time. If you have to, just delete and redownload. – Kaizerwolf Aug 3 '17 at 16:48
  • @Kaizerwolf check my edit – MCMastery Aug 3 '17 at 16:48
  • 1
    @MCMastery hmmm, headscratcher indeed. It's not a great solution, but you could try adding the ED shorcut as if it were a non-steam game would save you from redownloading if you want to save bandwidth. – Malco Aug 3 '17 at 16:52
1

I'm unsure as to the cause, but there's a couple of ways to fix this:

  1. Click install, point Steam to the existing library location and instead of downloading and reinstalling the whole game, it should say something along the lines of "Discovering existing files for Elite: Dangerous", and it will verify your local files against the current version hosted on Steam. It may take a while to compare ~25GB of files, but ultimately it should realise that everything is there, and identify the game as installed/playable without actually downloading anything. This has always been the case for me.

  2. Find another user who has Elite: Dangerous installed, and get a copy of the following file from them: [steam folder]\SteamApps\appmanifest_359320.acf . This is the app manifest that tells Steam what the status of an "installed" game is, where 359320 is the AppID for Elite: Dangerous. There should be an .acf file for each game you have installed (or downloading). A StateFlags value of "4" in the app manifest means the game is installed and ready to play.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.