1

I have tried to get my followers to use the Pillar of Sacrifice both for Boethiah's Calling and to upgrade my Ebony Blade, but the ones I've tried so far haven't worked.

  • Onmund, College of Winterhold
  • Cosnach, Silver-Blood Inn
  • Recorder, Recorder Standalone mod
  • Marcurio, The Bee and Barb

These 4 would just face me and say something like "Got it." but not touch the pillar. Then I tried telling Sofia (also a mod) to use it, but she never even activated the floor to glow in the first place. I'm sure it is just a glitch concerning my mods, but I don't know how to show my full mod list because I have downloaded mods through the ingame Mods option AND from Nexus using NMM, and I don't remember the directories for either of them. I have Skyrim SE and USSEP.

I have also referred to this article but it did not help me.

  • I had issues with this too... I think you need to actually direct them to directly interact with the Pillar (it's been a while) – Ben Aug 10 '17 at 23:42
  • Are they tagged as Essential? (Mod followers usually are). If they are that's probably why they're refusing to interact with the pillar – JonK Aug 11 '17 at 6:54
  • I wasn't going to sacrifice Sofia or Recorder (I would just load a save), but I wanted to see if they would interact with it at all. And I just checked and neither Onmund nor Cosnach are essential at any time in the game. – xRup7ur3x Thanatos Aug 11 '17 at 7:06
2

I had the same problem. Got Cosnach, but nothing would happen when I asked him to click the pillar. Figured out one of my follower-management mods was causing it. One of its options made my followers unkillable. I unchecked that option for Cosnach, and bingo, got the quest working.

-1

Bit late and a necro but if you put your weapon away and wait for your follower to put his away before you command them to activate it will generally fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.