I've started playing Pokemon Diamond on the DeSmuME Emulator for Nintendo DS(desmume-0.9.11-win32<-This is the version I'm Using). For some reason, when I try to save ingame I cannot save and it shows me what you can see in the image. I tried saving through the emulator itself as a save state and it worked every time but for some reason, I cannot save ingame. My friend also started playing this game same time as me, and he has no problem saving ingame(We use the same emulator and the same Pokemon Diamond ROM).

Screenshot from game

  • Diriector_Doc is correct and the same question was asked for Black 2. Even for ROMs you need to delete (or move on PC) any previous save files before saving a new game. Commented Aug 16, 2017 at 15:04
  • I thought most DS Pokemon games had some pretty hefty copy protection on them to prevent roms? I could be mistaken though.
    – Ramirez
    Commented Aug 16, 2017 at 15:07

2 Answers 2


On every version of pokemon, even in the official games, you need to delete the original save before you can save in a new game.

For pokemon DPP, go to the startup screen and hold UP + SELECT + B, or whatever they are bound to, to delete the save, THEN start a new game. This allows you to save the game on a new save.


So I've tried many things, and finally it worked. I haven't suspected the ROM since it worked for my friend, but today I've tried using another ROM for Pokemon Diamond and I could finally save ingame. I can't explain how or why that was the issue(because I don't know myself).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .