according to this page:


GRID 2 Reloaded Edition for Mac should support the PS4 controller. But I'm unable to use it. Is there anything I need to do?

enter image description here

My controller is connected over BT, but I also tried it with the USB cable. It's working properly with OpenEMU. Do I need a driver?

Apparently the needed drivers are there:

enter image description here

according to: http://www.mactrast.com/2013/12/feral-interactive-adds-playstation-4-dualshock-4-controller-support-many-mac-games/

But it doesn't work...


3 Answers 3


I managed to get it working in the end. What everyone said here is true. But, when you start the game and choose your expected PS4 controller to be plugged in, it doesn't show. After you go through all their stupid introduction menus, you'll eventually get to the screen of direct inputs, under the controller/key settings. This even works on a MacPro 4,1->5,1 on Mojave without the CUDA drivers on a GTX770 card.


I have it working when using the USB cable.

I have to set up my PS4 controller each time I start the game though, going to the controller options menu within Grid 2 and selecting the 'direct input' option.

I'm pretty sure I had it working previously without doing that too, but can't seem to get that going again.


I've tried it on various Mac computers at my college's graphic design lab, and also compared it to my own Mac, and a friend's own personal Mac. The PS4 controllers worked flawlessly with BT and wired on the personal Macs, but not the labs' computers. The labs' computers detected the controller, but were unable to update the drivers as I had no administrative access to install it. I found that it's usually a driver update that needs to be run because of this. Steam has an easy automated one that you can run by simply going into Big Picture Mode with the controller plugged in via cord. When you open the Big Picture Mode, it should say that your drivers need to be updated, and just go off of that. If you're unsure whether or not the computer detects it, just click on the Apple Icon, About This Mac, System Report, USB, and double click on "Wireless Controller" if you see it. Otherwise i'm unsure how to help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .