12

enter image description here

This is all servers, not just one.

The error says:

io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information:

Version 1.12

I've tried:

  • Restarting Minecraft
  • Restarting Computer
  • Uninstalling and Reinstalling Mincraft
  • Uninstalling and Reinstalling Java
  • Altering Firewall
  • Restarting Internet
  • I've messed with my port, made a second windows account, reset netsh winsock
  • Checked hosts
  • Made a new WINDOWS account

A Mojang support ticket wouldn't help. Im desperate.

  • 3
    Is your Minecraft modded? You have some buttons on the bottom right that I don't know. – Fabian Röling Aug 23 '17 at 20:53
  • Could you also add the results of a traceroute in terminal/command prompt (to the IP address of a minecraft server) along with a launcher log of the error? (To get the full launcher logs, open the launcher to start the game and go to settings and enable "Keep Launcher open when game is running" and "open output log when the game starts." Then, launch the game, try to connect to server, and copy the log output.) – getfugu Aug 24 '17 at 1:58
  • 2
    The bottom right is Geforce Overlay for game capturing, and no - not modded. I can get that to you in a hour or so - I'm in the middle of something currently - sorry. – Kongos Aug 24 '17 at 3:08
  • 1
    Windows CMD -> ipconfig /flushdns or try using a different/public DNS server (network -> properties -> ip v4 -> properties)... easy to do and sometimes it helps. – dly Aug 24 '17 at 6:52
  • Are you using Windows 10? – TooCleverFox Dec 4 '18 at 17:23
4

I have the same error on my local network, it looks like a firewall issue on the host/server side. For me, to troubleshoot I used nmap. The LAN game showed up in multiplayer as 10.0.0.21:49299. nmap reported that port from that IP as closed/filtered; i.e. a firewall issue.

To confirm it is a firewall issue, turn off the firewall (momentarily). See if you're able to connect while the firewall is disabled.

  • AVG Business was blocking it for me, standard AVG let it through fine :-) Still working out how to add rule for it. – The Coder Sep 5 at 9:56
0

It looks like it has something to do with Firewall not allowing traffic to the 1.12.jar file located in C:\Users\user\AppData\Roaming.minecraft\versions(version).

I assume that when you say you have "Altered the Firewall" you mean that you only allowed connections to the Java.exes but NOT the actual 1.12.jar file itself.

Important: When creating the rule it is important to make sure these configureations are set: Set the program path to the 1.12.jar file, and make sure to check "Allow the Connection" when configuring the rule.

protected by Community Oct 6 '17 at 5:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.