1

The current commands I have are:

/summon wolf ~ ~1 ~ {CustomName:"test",CustomNameVisible:1,Tags:["test"],CollarColor:0,Sitting:0,Passengers:[{id:"wolf",CollarColor:0,Sitting:0}]}

and

/tp @e[tag=test,c=1] @e[type=player]

I'm on multiplayer for Minecraft, but I can't use these commands combined to teleport a mounted mob with the mob it's mounted on.

1
  • What happens? Error message? Some unexpected behavior? I'm not completely sure how this behaves in the current version, but it probably has a very similar cause to bugs.mojang.com/browse/MC-67? Aug 24, 2017 at 21:05

1 Answer 1

1

I removed the tag from the first command as it is not formatted correctly and is not needed. Here is the command I used:

/summon wolf ~ ~1 ~ {CustomName:"test",CustomNameVisible:1,CollarColor:0,Sitting:0,Passengers:[{id:"wolf",CollarColor:0,Sitting:0}]}

Your command to teleport uses the tag target selector argument(tag=test), which is used with scoreboard tags. It is easier to use the name argument(name=test).

This would give you: /tp @e[name=test,c=1] @p

I ran this command and it does run properly. If you wanted to be more specific in selecting you could add type=wolf to the target selector.

This would give you: /tp @e[name=test,c=1,type=wolf] @p

This teleports them to the nearest player(@p). You can then be more specific with the target selector for the player to teleport them to.

Also, to note, if you were to name the passenger and teleport the passenger, it would split them up and only teleport the passenger.

6
  • Just FYI, /tp will not restrict the first argument to a single entity. I'm pretty sure it will either fail or implicitly add a c=1 to the second argument, but there's nothing stopping you from teleporting more then one entity unless you specifically target a single entity.
    – MBraedley
    Aug 24, 2017 at 23:12
  • I actually just read that it only defaults to 1 for @p or @r. Thank you. I have edited my answer.
    – IronAnvil
    Aug 24, 2017 at 23:14
  • still doesn't work on my server but when I kill the top wolf it then teleports to me but I want to teleport both of them while having them ride eachother
    – user195647
    Aug 24, 2017 at 23:52
  • This works properly on a stock server. Is your server a modified server? (Bukkit, Spigot, etc.) If so, which?
    – IronAnvil
    Aug 25, 2017 at 1:09
  • My server is Bukkit modified
    – user195647
    Aug 25, 2017 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .