21

I cannot go past level 3/4 because when I enter in rooms full of monsters the game start lagging a lot and controls do not respond at all or with a huge delay.

My configuration is not actually bad: Phenom X3 720 3Ghz + ATI 6850 HD + 4GB RAM

Do you have any idea how can I improve the performance of this game (that it is Flash based if I undestood well)? At the moment it is unplayable and very frustrating after first two levels.

UPDATE: I hoped that with DLC they took some times to optimize the code but unfortunately the problem is still there.

  • Did you try running some sort of resource monitor to try and see just what it is the game is hogging to cause the slowdown? I personally suspect this is some sort of software/hardware compatibility issue, as the game chugs along reasonably well on my aging 4 year old laptop (not to mention it runs just fine on my desktop, which I believe yours outspecs). – Aubergine Oct 6 '11 at 6:37
  • I have all other programs close, except Steam. I tried to open the task manager while having this lagging and delay issues and I saw that Isaac's process consume 40/50% of CPU. – Drake Oct 6 '11 at 7:21
  • My, my, I never saw it go over 6% at most. Did you try seeing how your computer handles heavy flash animations? This thing has my chrome at 25% CPU on my desktop (so effectively it grinds one entire core on my CPU). – Aubergine Oct 6 '11 at 16:46
  • @Aubergine That thing took my CPU to around 30% and it registered between 40 and 50 fps. – Drake Oct 6 '11 at 17:39
  • 1
    You could try this: forums.steampowered.com/forums/… – mordi2k Oct 8 '11 at 23:08

11 Answers 11

9

I saw this from another forum. The lag is akin to "walk on ice", so you will still move to a direction a few milliseconds after having released the directional button.

There is one setting in the graphic options that will solve that. Set the details to "Low". That is it, no more lag. It is probably related to flash overall poor performances. It changes the game from unplayable to "omg its soooo good".

| improve this answer | |
  • 3
    Yes, "walk on ice" are the right words to describe it. Unfortunately my settings are already set to "Low", and I have the same effect. With a lot of luck yesterday I reached Mom but during the fight the effect was terrible and miserably lost. – Drake Jan 31 '12 at 12:12
  • The developer said it himself, he's added so much to the game that Flash just crashes. rockpapershotgun.com/2012/08/30/… – Slurpee Jan 22 '13 at 17:56
5

It's probably Flash hogging up your on-board RAM and CPU power.

The Phenom II has a CPU speed throttling and power saving feature called "Cool'n'Quiet", where it undervolts your CPU when under low load. Try turning this feature off in the BIOS and see if that helps your frame rates.

| improve this answer | |
  • 3
    I was a bit skeptic about it, but I tried anyway. No results, from disabling Cool'n Quiet BIOS feature. – Drake Feb 1 '12 at 10:12
  • Are there any changes in improvement if you play in full screen mode? Also what resolution are you running at? – Krazer Feb 4 '12 at 0:14
  • I tried both playing fullscreen and in window. I try reduced also the resolution to minimum, but same effect. – Drake Feb 4 '12 at 0:31
  • By resolution, I meant screen resolution, not detail. E.g. 800x600, 1024x768; – Krazer Feb 4 '12 at 0:37
  • Are you on XP or W7? Try changing your performance to "Better Performance" in the "Advanced" tab under "System Properties" in Control Panel. – Krazer Feb 4 '12 at 0:46
2

From personal experience I found that the only way to get Binding of Isaac running smoothly is to play the steam version via wine. Neither running the windows version on windows, the windows standalone version in wine or the linux version on linux helped, but using the steam version in wine causes the game to run great. Every lag is gone, even setting the details to the highest possible value does not affect performance anymore.

| improve this answer | |
  • It seems interesting, but I never used Wine on Windows, can you expand a bit your answer? – Drake Apr 12 '12 at 23:43
  • Oh, Wine on Windows? I'm not sure if that's even possible. – Wieland May 4 '12 at 8:32
2

The reason for the slowdown is not your computer, but the game itself. It's coded in Actionscript, which is designed for use in Flash files, so whenever too much happens the engine just can't handle it all.

| improve this answer | |
  • 1
    You're not wrong, but this still doesn't quite seem to be the answer that the question warrants. – nine Sep 29 '15 at 20:01
1

To reduce the effect of this dreadful bug, make sure you play the game on 800x600 fullscreen mode, small window and lowest details setting.

To get rid of it for good: after running the game, press Ctrl+Alt+Del to invoke Windows Task Manager, select the Processes tab, find the Isaac.exe process, and right-click it. Choose Set Priority > Below Normal. Albeit counter-intuitive, this actually decreases the priority of the game engine process which allows for faster processing of key presses by Flash. This fix works for WotL v1.48 and the original BoI, and I posted this fix on the wiki.

Note that the game will still be slow (which helps you to avoid some shots) but it will react to keys immediately.

| improve this answer | |
0

I know this question is quite old by now, but the best way to play The Binding of Isaac on modern systems is to play The Binding of Isaac: Rebirth instead. It's a rewrite of the game to be native instead of Flash so doesn't have the issues that the original did.

At this point, it also has two expansions with a third on the way.

| improve this answer | |
0

So this MIGHT sound crazy but with my setup (i7-3770s, 16 GB RAM, Gigabyte GTX 1050 SC 3 GB VRAM) my first launch saw the game run in slow motion. Obviously not the PC, but having played it on Xbox I knew the game wasn't just lagging from things flooding the screen, it was slow from the start. So I found people had luck with switching Vsync off, but I know my display shouldn't hamper the game from that so I browsed the other options. My fix came from simply doubling the number value for MaxRenderScale, from 2 to 4. Saved the .ini file, restarted the game and smooth as butter for me now. Hope this helps others having a stupid struggle to run this game in 2020.

| improve this answer | |
-1

It's because the game is written in flash and flash can't handle the kind of stuff this game is trying to do. There's not much you're going to be able to do to fix this outside of waiting for the remake

| improve this answer | |
  • Technically, it's more because this game in particular is poorly optimized. There are games in Flash which are performing perfectly for the same kind of demand, or more. – Gnoupi Jan 22 '13 at 16:57
  • I love this game but frustrated because I cannot finish it due to performance issues. I hope to upgrade my CPU soon or eventually wait the remake. – Drake Jan 23 '13 at 9:54
  • I'm in the same boat, I just uninstalled it because of the performance but wish I could have finished it.. I have an i7 2670 and that wasn't enough. Fine example of why it takes more than just a good idea and passion to make a game. If you have no f'ing clue what you are doing as a game design you can make the best game in the world and it's still going to be a crappy experience for all :( – unc0nnected Feb 13 '13 at 20:35
-1

I managed to fix this problem by deleting the settings and cache in Control Panel > Flash > Advanced

| improve this answer | |
-1

going full screen solved my problem. runs super fast.

| improve this answer | |
  • This is a helpful, but very brief answer. What kind of specs do you have? What kind of performance were you seeing before and after this? That would be helpful information to add :) – two bugs Jul 8 '16 at 14:24
-3

Being that your CPU and GPU are more than powerful enough to handle the game, the only thing I could suggest as the problem would be your RAM.

The game is probably having trouble handling all the data for the enemies due to insufficient RAM.

| improve this answer | |
  • 1
    Thanks for comment, but I have 4 GB of RAM (I updated my question now) and I have no other applications than Steam running in background. – Drake Feb 2 '12 at 16:47
  • In that case, I am unable to help you as I don't own the game so I can't test it for myself. – Ryan S. Feb 2 '12 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.