4

When i try to launch Geometry Dash, the following things happen:

  1. 'Running' appears next to the game in my library.
  2. A 'Preparing to Launch' window appears for a short while.
  3. My profile picture turns green.

It stays like this for a while, maybe about 4 seconds, then the 'Running' message disappears and my profile picture returns to blue. There is never any error message or window.

I have tried everything that every forum says to do including:

  • reinstalling the game
  • verifying game files
  • running from program files
  • resinstalling visual c++
  • reinstalling steam completly.

Does anyone know how to fix this?

Specs:

  • OS Name: Microsoft Windows 10 Home
  • Version: 10.0.14393 Build 14393
  • Processor: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2701 Mhz, 2 Core(s), 4
  • Logical Processor(s)
  • RAM: 8Gb
  • Graphics: Intel(R) HD Graphics 620

Update: I used event viewer and located the prolbem to be in libcocos2d.dll

Faulting application name: GeometryDash.exe
Faulting module name: libcocos2d.dll, version: 0.0.0.0
Exception code: 0xc0000005
Fault offset: 0x000e8045
Faulting process id: 0x2268
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Geometry Dash\GeometryDash.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\Geometry Dash\libcocos2d.dll

Update #2: Compatibility mode

I tried running it in every compatibility mode. It would never run if i tried the .exe in steam apps, but if i tried running it through the steam client, windows 95 and windows 98/me worked. however the audio quality in that the lower range of frequency were reduced to broken static.

Update #3: Solved

I have solved the problem and posted the solution as an answer

  • Did you try running compatibility mode for Windows 7 or Windows XP? If that works let me know and I'll craft an answer. – Kaizerwolf Sep 14 '17 at 12:52
  • When running from program files, use a command shell to see if any error messages are being displayed – npst Sep 14 '17 at 14:53
  • This happened to me a while back, contacted their support, no answer. – Bucky Sep 14 '17 at 15:57
  • @npst I used event viewer and found it is a prolbem with libcocos2d.dll. I have updated the question – beck5 Sep 15 '17 at 0:18
  • @Kaizerwolf Thanks for your help. I tried running it in every compatibility mode. I have updated the question. – beck5 Sep 15 '17 at 0:39
2

Solved!

After many attempts, this prolbem has finally been resolved. This is how I did it.

In the end, all i needed to do was to completely uninstall Geometry Dash (or, I presume, what every game this problem is occuring with). First I uninstalled the game through the steam client. Then, I installed void tools everything. this is basically a very good and fast index searcher. By searching for 'geometry dash' I was able to delete all the files that were left on my pc after the game was supposedly uninstalled by steam. These files caused the problem. After this, I used the change/uninstall a program menu to uninstall steam, then reinstalled steam and downloaded the game and it worked.

  • Sometimes external libraries use an installer that doesn't really verify the files, so if the external libraries are corrupted, then the standard Uninstall/Install from Steam won't work. – Nelson Aug 28 '18 at 0:32
0

Or you can manually start the game's executable outside of Steam and then manually close it. This will reset its status with Steam.

0

NOTE: THIS PROBABLY DOESN'T APPLY TO OP, BUT MAY HELP ANYBODY ELSE

This has happened to me, and I have found a solution.

When your computer starts up, there is a Steam pop-up which says "Verifying installation" (or like that in the future or the past).

If you close that window, then Steam games will not start. Instead, you have to wait it out.

TL;DR Restart your computer and do not close out Steam.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.