1

From the very start of the game on Xbox 360, I have never been able to recruit any followers that weren't part of a quest.

From everything I've seen on the internet, I've tried waiting, dying, and fast travelling. I have done these many times as I've been playing for many weeks so far.

For some reason, everyone says:

"It looks like you already have someone"

Also, I'm not sure about Lydia. She stays in my house in Whiterun, but doesn't follow me when I ask her to, and just says "An honor to see you, Thane" or something along those lines.

I haven't been able to find anyone who could fix this problem yet.

  • Check your quest log for any quest mentioning something like, escort x to location x, or in similair fashion. – KevinTheGreat Sep 19 '17 at 10:53
  • If you're in the middle of a quest that requires a follower you'll be unable to recruit another follower until you finish said quest. What quests do you have currently in progress? – onewho Sep 19 '17 at 18:16
1

This question may be almost a month old but in the interest of future readers here's a potential solution I just found on the Notes section of this page:

When a new recruit joins the Blades, they automatically leave your service, so a new follower can be recruited. Bugs affecting your ability to obtain new followers may be solved in this manner, though only three followers may be recruited.

So, inducting someone into the Blades forces them from your service. Even if they don't turn up to Sky Haven Temple the scripts should still run. I'm unable to test this as my game isn't exhibiting the bug.

Obviously this has a few problems (if it works, of course):

  • It relies on you having the quest available and not having already completed it
  • You can only induct 3 followers so this could be a waste, depending on whether or not your follower turns up at Sky Haven Temple eventually
  • You may simply not want this follower to become a Blade - the process cannot be reversed

I hope this helps, I'm just conveying what I read on the UESP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.