In Warcraft 3: The Frozen Throne, when you try to load some maps, an message appear explaining (not much) «this map file is too big. please choose a different map».

But why this happens? How to solve this and play the map?

I tried to play some maps like Lordaeron The Aftermath, and Lordaeron The Foremath in Singleplayer, with computer (bots), but the message keeps appearing to me.

My Warcraft version is, and files I'm trying to play are respectively, 8.10MB, and 26.2MB, although I tried to play others maps with 29.743MB, 11.188MB and didn't worked either.

  • How big are those maps? I believe there is a 3-4MB limit – Tas Oct 2 '17 at 23:09
  • More than the 8MB @Tas – user195122 Oct 3 '17 at 0:24
  • 1
    I have not tried it, but maybe this helps dota682.com/game-dll-warcraft-iii-8mb-limit-remover – Kaffeleif Oct 3 '17 at 20:48
  • 1
    @Kaffeleif the link you shared fixed my problem =D thank you. – user195122 Oct 4 '17 at 16:32

Patch 1.27b (Dec. 2016) raised the vanilla map size limit from 8MB to 128MB. Update your game.

Backwards compatibility hasn't been broken significantly since patch 1.24b, but forward compatibility is not guaranteed, so it's not impossible that custom maps made with newer game versions in mind won't work properly on older versions.

|improve this answer|||||

As @Kaffeleif said in comments, I've used the Warcraft III 8MB Limit Remover. Changing the game .dll fixed my problem, and now all maps I asked for help are working properly.

It's necessary to do the following:

  • Download the patch, respectively to the 1.24 version or 1.26 version.
  • Extract the .zip file.
  • Copy and Paste the game.dll file to the Warcraft III folder.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy