I typed /kill @e into a repeating, always active command block.

Now whenever I respawn, I am immediately killed. I've tried to use world edit but was unable to correct the situation.

  • 1
    Not a duplicate, but it has the same solution. I recommend letting it stand and linking. – Shadur Oct 8 '17 at 12:20
  • 1
    I suggested an edit for the most popular answer, but I wanted to make sure you saw it. In the future use /kill @e{type=!Player} – Sam Oct 8 '17 at 23:24

Go download NBTExplorer. It's free. It is a small editor for NBT files.

Open it. Click on the world name you want to search. (In my case BigRed)


Open Search menu, click Find menu.

Check the Name check box and type Command in the search field, type kill in the value field and click Find.


It will find that command block and you will see something like this:


Make sure you don't have the world open in minecraft and double click the line containing Command and set the command value to nothing from NBTExplorer. Click File -> Save before trying to play the world. When you go to that command block in game, the command portion will be blank.

Another option if you don't want to clear the command block is to double click the line above the command line that says auto: 1 and set it to 0. This would change the command block from Always Active to Needs Redstone

Also, if you don't know where that command block is, NBTExplorer is showing you the command block coordinates. In my case x:66, y:40 z:-50.


Open the world in MCedit (a free program) and delete the commandblock.


You can open the world as a server with command blocks disabled (already set by default), join it and just break the command block. A tutorial for this is here (archive).

Not the answer you're looking for? Browse other questions tagged or ask your own question.