When exploring on my friend's server, not all of my map's pixels are filled in. It looks like it's just the pixels around the corners of a medium-sized square around my position.

This bug is mentioned on the wiki page, but no solution is provided.

I've tried making new maps, but that didn't help.

Is there a workaround for this bug, or do I just have to wait for an official fix?

enter image description here

  • Can you upload a screenshot?
    – Ken
    Oct 13, 2011 at 1:34
  • @Kort Image uploaded.
    – Maxpm
    Oct 14, 2011 at 2:20
  • The Wiki does seem to suggest a fix: "Giving the map to another player and having them give it back or putting the map in a chest and taking it out again seems to fix this until they log off again."
    – fredley
    Oct 14, 2011 at 10:40
  • @fredley I just tested that with a chest, and it had no effect.
    – Maxpm
    Oct 14, 2011 at 20:23

3 Answers 3


The way to have this fixed is for the server to be configured/modded to load chunks in a larger radius than the map updates. When the chunk is unloaded, it gets put on the map as empty space. This increases bandwidth a lot though, because more junk is being sent to your clients.


Are you sure you have those chunks loaded?

Also, have you tried reinstalling minecraft to see if that fixes it. (especially if you have mods, you do not know if one of them has had any unknown affects.

  • I'm pretty sure the chunks are loaded by the server, at least. This is on a fresh Minecraft install, and my friends experience the same problem, anyway.
    – Maxpm
    Oct 23, 2011 at 7:28

I have encountered this problem several times, and getting the server administrator to restart the server and dump the RAM has always fixed the problem. If you're in a position to do so, see if you can get the server restarted somehow.

  • 7
    ...and dump the RAM... Wait, what?
    – Bobby
    Nov 13, 2011 at 11:34
  • 2
    Do you mean that the server software must be restarted, or the whole server computer must be?
    – Maxpm
    Nov 13, 2011 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .