1

SO, the minecraft launcher was recently updated, and the JVM arguments no longer appears when I try to edit a launch setting. How do I allocate more ram now? Edit: My apologies, I forgot to enable advanced settings

  • If my answer solved your problem, please accept it. – D-Inventor Oct 9 '17 at 4:33
4

First you go to launch options, then you select the profile for which you want to change the arguments, then you enable JVM arguments and you can then change the arguments in the entry next to the switch. You might need to enable Advanced settings, which you can see in the first image.

enter image description here

enter image description here

1

Ok, so pretty much D-Inventor's Answer, but easier. First go to Launch Options in the launcher, and check the advanced settings slider

Then, you want to go to the release you want (Click Latest release), and tick the JVM Arguments box.

JVM Arguments Box

After that, choose how much RAM you want from this chart:

2GB: -Xmx2G

4GB: -Xmx4G

6GB: -Xmx6G

8GB: -Xmx8G
etc..

After you've chosen your RAM, change the part in JVM Arguments that says -Xmx2G (or whatever it says), and replace it with the code in the chart above, and click save. You're welcome :).

-Xmx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.