2

Alright so to those World of Warcraft gamers and tech enthusiast out there, I got a tricky question for you.

It is no longer possible to install WoW on a NAS (Network Attached Storage). See:

https://us.battle.net/support/en/article/30780

There is one sure work around which requires setting up and installing wow on a VHD/VHDX. See comments from CanadianKB:

https://eu.battle.net/forums/en/d3/topic/12618121738#post-8

When running on a HDD based array on your NAS, the performance is very different when running in a VHD environment vs non-VHD. However I have a SSD Raid 0 NAS that sees no performance difference what-so-ever when using it in a VHD manner.

Alas, that's not the problem. The problem is that a VHD/VHDX can only be accessed or mounted by one single system or user:

The process cannot access the file because it is being used by another process.

Therefore for every user on your network playing WoW, you will need a separate VHD/VHDX file with it's own WoW installation. In my opinion, this greatly ruins a huge beneficial chunk of having a NAS: having a single set of similar data for all local PCs. Not only that, since the file would always constantly be "in use" because it is mounted, any backup system of the your NAS system will fail:

Failed to copy from Source : Cannot copy file (1117): The request could not be performed because of an I/O device error.

So I started working with Symbolic and Hard links using the cmd mklink.

First thing I tried was making the hard link with the /J switch, but got the error:

Local volumes are required to complete the operation.

So I tried a symbolic (aka soft) link, in which the command completed successfully. However Blizzard's Battle.net app still was able to pick up that it was networked, of course. :( Now I tried to get a little creative. I copied everything over from the NAS main WoW folder to VHD WoW folder except the huge chunk of data files found under /Data/data. Then I created a symbolic link to the data folder. Still got an error on the Battle.Net app, however I don't get an error about network drives like before, just a generic error:

https://us.battle.net/support/en/article/2667

I'm at a loss. I really don't see any reason why Blizzard made this ridiculous change. After all it works fine on the VHD that resides on the NAS itself. There's got to be a better workaround solution?

Any ideas?

EDIT The NAS backup does successfully complete with that VHD while mounted/in-use. The error I was experiencing was for another VHD, ironically.

  • Honestly, I don't think we'll be able to help much more than what's at your link; that error seems almost deliberately vague. – Frank Oct 19 '17 at 0:59
  • @frank, ya it sure is! But that’s what we pay for, right blizzard! Haha... – Gerneio Oct 19 '17 at 1:07
  • I just found something that might help you with your symbolic link problem. Hopefully it'll help. superuser.com/q/560781/215659 – Nolonar Oct 19 '17 at 1:12
  • @Nolonar unfortunately that won’t help in my case as I am not having an issue creating a symbolic link, just a hard link, which I bet would solve this issue 100%. Thanks though! I did learn some new info. – Gerneio Oct 19 '17 at 1:18
  • 1
    You're not going to be able to fool the updater with links or junction points. Windows will accurately report that the files exist on the network. VHDs work because there's additional layer of indirection that makes it look to the Windows APIs that files are stored locally. Normal file access is: App -> Win32 API -> NTFS File System -> Harddisk. Normal network file access is: App -> Win32 -> Network Redirector -> Network -> NAS. Accessing a file in a VHD stored on the network is: App -> Win32 -> NTFS FS -> VHD driver -> Network Redirector -> Network -> NAS. – user86571 Oct 19 '17 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.