0

So I was doing a command creation where I can create my own food in Minecraft.

One of my commands is this command, which is what I am talking about that is not working:

testfor @a[score_name_min=0,score_name=0]

The command block should say this if I am not tested, right?:

samplePlayer don't match the data structure... something like that

or if I am found, it should say:

Found samplePlayer

but instead of showing these responses, it shows none. Really none.

I also tried this using /give command, like this:

give @a[score_name_min=0,score_name=0] minecraft:carrot 1 0

but still the same, nothing happened. The command didn't respond, even though my score in objective name is 0.

My goal here is to get my exact score. Because if I just typed: testfor @a[score_name_min=0], the command will test every entity in the world who has a score of 0 or higher at objective name.

So can anyone help me, how can I make this work?

My main problem, to make the problem more specific, is to make score_name work, because every time I use score_name only, the command won't work.

  • I think the "data structure" error message comes only if you match something with the selector, but not the NBT data. The error message in your case would be "selector [...] found nothing". Are you playing in 1.12.2? – Fabian Röling Oct 26 '17 at 9:26
  • Try /say lalala @a[score_name_min=0,score_name=0], what do you get? – Fabian Röling Oct 26 '17 at 9:31
  • @Fabian I am playing at 1.8.9 right now. – scriptmastere02 Oct 26 '17 at 9:39
  • @Fabian shows this on chat: That player cannot be found. – scriptmastere02 Oct 26 '17 at 9:40
  • To your first comment: Then you should have said that in the question. Can you try if the same happens in 1.12.2? (Don't just upgrade and downgrade the world, copy it or you'll destroy it with the downgrade.) To your second comment: What do you mean? I don't understand that sentence. If you mean I should look in chat, I can't currently, because my work laptop blocks it. – Fabian Röling Oct 26 '17 at 9:42
1

This was apparently a bug in 1.8.9, the version you used. It is fixed in 1.12.2.

  • sorry if it's just now that I marked it.. I am very sorry.. – scriptmastere02 Dec 6 '17 at 10:12
  • No problem, there are people who take longer. And it's not mandatory anyway. – Fabian Röling Dec 6 '17 at 10:55
0

If you don't have any output appearing in your command blocks, you might want to turn the gamerule sendCommandFeedback to true instead, and then place your command block.

  • My sendCommandFeedback is ON true. – scriptmastere02 Oct 26 '17 at 9:16
  • @scriptmastere02 Does the output box appear in the command block? If it doesn't you can simply press the x at the right. – Mika Oct 26 '17 at 9:18
  • It is on O before i tried the command, not in X. – scriptmastere02 Oct 26 '17 at 9:20
  • + yes it is showing. – scriptmastere02 Oct 26 '17 at 9:22
  • If you do this in a command block, the gamerule is commandBlockOutput. – Fabian Röling Oct 26 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.