6

I recently switched to a Pixel 2 XL and have been unable to connect through data since. The game works fine on wifi and will even stop working when switched to data.

I have tried numerous fixes online such as making sure background data is allowed for the app, Google services, and the Google play store. I tweaked my Google account security settings, cleared out all my settings, and even removed all my Google account data and re-added it through the app.

I've reached the point of frustration, and I'm out of solutions. If anyone can help me with this issue it would be much appreciated. I'm unsure if it's a Pixel issue, Android Oreo issue, or a Pokemon Go issue. Any and all help is appreciated.

  • 3
    Are other apps able to connect while on data, or is it only Pokemon Go? – Wondercricket Oct 27 '17 at 20:46
  • I have had no issues with other apps on data so far. I am playing in the US. Additionally, it won't connect with a Pokemon Trainer Club account making me think it's a phone issue. – Ryan Fouts Oct 27 '17 at 20:53
  • Not a particularly helpful comment, but I am running the first Pixel which I have updated to Oreo and have no issues with Pokemon Go; however, I am using a google account login rather than a trainer account. I suspect, if anything, it is a Pixel 2 issue. Do you usually use agoogle account or trainer account to log in to Pokemon Go? – Theyna Oct 27 '17 at 23:11
  • Google account, but I tried a Trainer account. Same issue. – Ryan Fouts Oct 28 '17 at 1:40
  • 1
    Just to update this issue, I left the game uninstalled for the past week. Just re-downloaded to test some more solutions and the issue appears to be resolved. As far as I am aware nothing has changed, maybe they patched the issue? – Ryan Fouts Nov 4 '17 at 21:20
1

I'll assume you've tried all the things from all the "unable to authenticate" help threads last updated in 2016, and since you're on a modern Android deployment on a Google-branded phone, you'll already have Background Data enabled for Google Play Services. ;) Check your mobile data APN settings and see if it's set to use IPv6. If so, try forcing it to IPv4 only and see if that works. I use custom roms a lot, mostly AOSP Extended (which adds functional extensions but overall stays pretty close to AOSP stock rather than radically reskinning things and moving stuff around), and recently the builds for my phone jumped up to Oreo 8.1, which broke my ability to authenticate while on mobile data. It used to work fine with my APN settings (I'm on MetroPCS, a T-Mobile reseller MVNO in the USA) on IPv6 but with 8.1 I had to set it back to IPv4 to get it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.