3

I have Super Mario Galaxy 2 in the Dolphin Emulator. Since I have to point for certain things and use the joystick on the nunchuck for general movement (and I don't have a USB sensor bar), I want to play with the nunchuck in my left hand and the computer mouse in my right hand, while the Wiimote just lies around (because I don't have a third hand).

This works fine (except for shaking, but that's a different question), but the Nunchuck joystick is apparently stuck at the top right, because Mario keeps walking in that direction. I can make him strafe a bit to the left or right using the joystick, but the overall direction stays the same.

Interestingly, if I click Movie->Start recording input, he doesn't do that anymore, but Mario keeps ducking and no input from the real Wiimote or nunchuck are accepted anymore. And apparently I can't turn recording off again by any other way than closing the game.

I tried separating the Nunchuck and reconnecting it to the Wiimote while playing, while in the home screen, while the game is not running, before connecting it to my PC, etc., but it doesn't help. I even tried holding it to the top right while connecting it to see if Mario stands still at the default position, but that changed nothing.

Setup:
American version of Super Mario Galaxy 2 (SB401?)
Dolphin 5.0 (ac267a29405ae768037a8774b84b805a4180d1af)
Windows 7 Professional 64bit +SP1

How do I stop this? If it's possible to just fix the "Start recording" behaviour, that would also be ok, although inconvenient, because I would have to click it every time I start the game.

(Possibly related question)

7
  • Is you Nunchuck defective?
    – OrangeDog
    Nov 11, 2017 at 16:17
  • No, it works fine if I use only the real Wiimote, but not with the hybrid. Nov 11, 2017 at 16:28
  • But that's not a solution, because I have to be able to point, which doesn't work with a real Wiimote that's connected via bluetooth. Maybe I could remap the arrow buttons on the real Wiimote to moving the cursor, but that just isn't playable, because I would have to regularly switch positions of my right hand and spam the arrow buttons. Nov 11, 2017 at 16:41
  • @Fabian Try enabling Continous Scanning in Dolphin's Controller Configuration. It has helped me when my controller dropped out, maybe that is what is happening to your nunchuck.
    – Mr McClean
    Nov 15, 2017 at 22:48
  • Continuous scanning is on. I also see the Bluetooth adapter blinking whenever the wiimote is connected and most importantly: I can still direct Mario a bit left or right of his direction using the nunchuck. So it's definitely connected, it's just sending the wrong data. Nov 15, 2017 at 23:25

1 Answer 1

1

From an answer from one of the developers of Dolphin (archive): This is a bug in the current version of Dolphin. It only affects hybrid Wiimote mode, emulated Wiimote mode works.

Hybrid Wiimote was removed in the current betas, because there are many bugs like this with it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .